bcrypt 安装不成功解决办法

同一个项目,公司和家里的 node.js 的版本不同,导致项目安装依赖包时 bcrypt 安装不成功。

家里的版本为:8.11.3

公司的版本为:10.14.2

在当前项目中执行完下面两个命令后,报错:

npm install
npm run start

报错集中为两处:

Error: Cannot find module 'bcrypt'

node-pre-gyp ERR! build error

bcrypt 没有安装成功!!!

 

Stack Overflow 解决办法如下,删除 node-gyp 可以不在当前项目下执行,其余2/3两步必须在当前项目下运行:
  1. npm -g uninstall node-gyp  全局删除  node-gyp
  2. npm install  再次安装依赖
  3. npm rebuild  更改包内容后重建

 

OK!

重新运行 npm run start

[nodemon] restarting due to changes...
[nodemon] starting `node server.js`
服务启动成功!
数据库连接成功!

 

发布了158 篇原创文章 · 获赞 25 · 访问量 20万+

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览