线性合并的应用 九度OJ 1004

题目描述:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
    Given two increasing sequences of integers, you are asked to find their median.

输入:

    Each input file may contain more than one test case.
    Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
    It is guaranteed that all the integers are in the range of long int.

输出:

    For each test case you should output the median of the two given sequences in a line.

样例输入:

4 11 12 13 14

5 9 10 15 16 17

样例输出:

13

———————————————————华丽分割线——————————————————

#include <iostream>

using namespace std;

void MergeArray(long int *a,long int *b,long int *c);  //非降序合并数组

int main()
{
    long int n,m;
    while(cin>>n)
    {
        long int *a=new long int[n+1];        //创建数组a
        a[0]=n;                     //数组第一个元素记录序列长度
        for(int i=1;i<=n;i++)
            cin>>a[i];

        cin>>m;
        long int *b=new long int[m+1];        //创建数组b
        b[0]=m;                     //数组第一个元素记录序列长度
        for(int i=1;i<=m;i++)
            cin>>b[i];

        long int *c=new long int[n+m+1];      //创建数组c
        c[0]=m+n;                   //数组第一个元素记录序列长度
        MergeArray(a,b,c);

        cout<<c[1+(m+n-1)/2]<<endl;   //输出中值
    }
    return 0;
}


void MergeArray(long int *a,long int *b,long int *c)
{//用到了数据结构中的线性表的合并
    long int *pa,*pb,*pc;
    pa=a+1;
    pb=b+1;
    pc=c+1;
    while(pa<=a+a[0]&&pb<=b+b[0]) //指针均未达到序列尾部
    {
        if(*pa<*pb)
        {
            *pc++=*pa++;
        }
        else
        {
            *pc++=*pb++;
        }
    }
    while(pa<=a+a[0])            //pb已达到尾部,将a中剩余元素拷贝到c
        *pc++=*pa++;
    while(pb<=b+b[0])            //pa已达到尾部,将b中剩余元素拷贝到c
        *pc++=*pb++;

}

//启示:数组型的线性表可以用数组第一个单元储存元素的个数n,此时数组长度为n+1


转载于:https://www.cnblogs.com/zhanyeye/p/9746127.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值