zoj 2417 Lowest Bit(简单的模拟)

Lowest Bit
Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input

 

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output

For each A in the input, output a line containing only its lowest bit.


Sample Input

26
88
0


Sample Output

2
8

分析:

(1)因为是100以内的数字所以只要找出能够组成100以内的所有二进制的数字然后一次减直到减后为0时就说明此时减掉的是最小有效位的那个数字。

复制代码
#include <stdio.h>

int main()
{
    int n,bit_num[7],i;
    //得到可以组成100以内的二进制数的组合
    bit_num[0] = 1;
    for(i = 1;i<7;i++)
    bit_num[i] = bit_num[i-1]*2;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(i=6;i>=0;i--)
        {
            if(n>=bit_num[i])
            n -= bit_num[i];
            if(n==0)break;
        }
        printf("%d\n",bit_num[i]);
    }
    return 0;
}
复制代码








本文转自NewPanderKing51CTO博客,原文链接: http://www.cnblogs.com/newpanderking/archive/2012/10/05/2712264.html  ,如需转载请自行联系原作者



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值