poj1258

Agri-Net

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18260 Accepted: 7324

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

40 4 9 214 0 8 179 8 0 1621 17 16 0

Sample Output

28

解题思路:类似2485,求最小生成树的edge的总和。prim

 
 
#include <iostream>
#include <cstdio>
#include <cstring>

#define MAX_VALUE 1e8

using namespace std;

int main()
{
    int N;
    int graph[101][101];
    int d[101];
    bool visit[101];
    int totaldist;

    while(scanf("%d",&N)!=EOF)
    {

        for(int i=1; i<=N; i++)
        {
            for(int j=1; j<=N; j++)
            {
                scanf("%d",&graph[i][j]);
            }
        }
        memset(visit,0,sizeof(visit));
        fill(d+1,d+N+1,MAX_VALUE);
        totaldist=0;

        //prim
        int minNode, minValue;
        minNode=1;
        for(int p=1; p<=N; p++)
        {
            minValue=MAX_VALUE;
            d[1]=0;
            for(int i=1; i<=N; i++)
            {
                if(!visit[i] && d[i]<minValue)
                {
                    minNode=i;
                    minValue=d[i];
                }
            }
            totaldist+=d[minNode];
            visit[minNode]=true;
            for(int i=1; i<=N; i++)
            {
                if(d[i]>graph[minNode][i])
                {
                    d[i]=graph[minNode][i];
                }
            }
        }
        printf("%d\n",totaldist);
    }
    return 0;
}


转载于:https://www.cnblogs.com/eric-blog/archive/2011/01/03/1924596.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值