Binary String Matching string(stl) find()函数的应用 完全不用kmp

题目来源:http://acm.nyist.net/JudgeOnline/problem.php?pid=5

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
 
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
 
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 


分析: string 中的find(string&,location) ,在一个字符串中查找指定的单个字符或字符组。如果找到,返回首次匹配的开始位置,如果没有找到匹配的内容,则返回 string::npos。,一般有2个输入参数,一个是待查询的字符串,一个是查询的起始位置,默认起始位置为0.
代码如下:
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <iostream>
#include <vector>
#include<string>
#include<cstring>
#include<string.h>
#include<set>
#include<queue>
using namespace std;
typedef long long ll;


int main()
{

    int t,ans;
    cin>>t;
    while(t--)
    {
        string p,t;
        int num=0;
        cin>>p>>t;
        ans=t.find(p);
        while(ans!=string::npos)
        {
            num++;
            ans=t.find(p,ans+1);
        }
        cout<<num<<endl;

    }
    return 0;
}

 

转载于:https://www.cnblogs.com/zn505119020/p/3620155.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值