HDU 3552 I can do it! 【贪心】

Problem Description
Given n elements, which have two properties, say Property A and Property B. For convenience, we use two integers A i and B i to measure the two properties.
Your task is, to partition the element into two sets, say Set A and Set B , which minimizes the value of max (x∈Set A) {A x}+max (y∈Set B) {B y}.
See sample test cases for further details.
 

 

Input
There are multiple test cases, the first line of input contains an integer denoting the number of test cases.
For each test case, the first line contains an integer N, indicates the number of elements. (1 <= N <= 100000)
For the next N lines, every line contains two integers A i and B i indicate the Property A and Property B of the ith element. (0 <= A i, B i <= 1000000000)
 

 

Output
For each test cases, output the minimum value.
 

 

Sample Input
1 3 1 100 2 100 3 1
 

 

Sample Output
Case 1: 3
View Code
/*
题目大意:一个元素分为2个属性,a和b。然后将元素分成2个集合A和B。求出A集合的a属性的最大值+B集合的b属性的最大值,的最小值 
解题思路:一篇很详细的结题报告
http://blog.csdn.net/dgq8211/article/details/7748078 
*/
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct Set
{
    int a, b;
}SS[100002];
int cmp(Set x, Set y)
{
    return x.a>y.a;
}
int main()
{
    int T, n, k=0, i;
    scanf("%d", &T);
    while(T--)
    {
        k++;
        scanf("%d", &n);
        for(i=0; i<n; i++)
        {
            scanf("%d%d", &SS[i].a, &SS[i].b);
        }
        sort(SS, SS+n, cmp);
        int maxsum=SS[0].a, maxb=SS[0].b;
        for(i=1; i<n; i++)
        {
            maxsum=min(maxsum, SS[i].a+maxb);
            maxb=max(maxb, SS[i].b);
        }
        printf("Case %d: %d\n", k, maxsum);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Hilda/archive/2013/03/03/2941587.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值