dp-最大递增子段和

 
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the maximum according to rules, and one line one case.
 

 

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
 

 

Sample Output
4 10 3
 
题目大意 :
   每次从最左端起点处走, 最右端是终点, 并且最左端视为无穷小, 最右端视为无穷大,每次走的下一个点必须比上一个点大,问走过后最大子段和是多少。
因为下一次走它会被上一次所影响,很容易想到dp,则状态转移方程为 dp[i] = max( dp[i], dp[j]+pre[i] ) 0 <= j < i , pre[i] > pre[j]。
 
代码示例 :
  
/*
 * Author:  renyi 
 * Created Time:  2017/8/31 13:51:36
 * File Name: 
 */
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <time.h>
using namespace std;
const int maxn = 1e6+5;
#define Max(a,b) a>b?a:b
#define Min(a,b) a>b?b:a
#define ll long long

ll t_cnt;
void t_st(){t_cnt=clock();}
void t_ot(){printf("you spent : %lldms\n", clock()-t_cnt);}
//开始t_st();
//结束t_ot();

int pre[1050];
int dp[1050];

int main() {
    int n ;
    
    while (~scanf ("%d", &n) && n){
        for (int i = 0; i < n; i++){
            scanf ("%d", &pre[i]);
        }
        
        int ans = 0;
        for(int i = 0; i < n; i++){
            dp[i] = pre[i];
            for(int j = 0; j < i ; j++){
                if (pre[i] > pre[j]){
                    dp[i] = Max(dp[i], dp[j]+pre[i]);
                }
            }
            ans = Max(ans, dp[i]);
        }  
        printf ("%d\n", ans);
    }


    return 0;
}

 

 

转载于:https://www.cnblogs.com/ccut-ry/p/7458738.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值