ACdream 1007 (快速幂)

题目链接

a + b

Time Limit: 2000/1000MS (Java/Others)Memory Limit: 128000/64000KB (Java/Others)
Problem Description
Input
Output
Sample Input
2
3 1
1 2 3
3 10
1 2 3
Sample Output
6
60074
 
  
/*************************************************************************
    > File Name: 1007.cpp
    > Author: Stomach_ache
    > Mail: sudaweitong@gmail.com
    > Created Time: 2014年08月11日 星期一 07时44分39秒
    > Propose: 
 ************************************************************************/
#include <cstdio>
/*Let's fight!!!*/

typedef long long LL;
const LL mod = (LL)1e10 + 7;

LL mul(LL a, LL b) {
      LL res = 0;
    while (b) {
          if (b&1) if ((res += a) >= mod) res -= mod;
        a <<= 1;
        if (a >= mod) a -= mod;
        b >>= 1;
    }
    return res;
}

LL mod_pow(LL a, LL b) {
      LL res = 1;
    while (b) {
          if (b&1) res = mul(res, a);
        a = mul(a, a);
        b >>= 1;
    }
    return res;
}

int main(void) {
    int t;
    scanf("%d", &t);
    while (t--) {
        LL n, k, ans = 0, x;
        scanf("%lld %lld", &n, &k);
        k %= 9560995488LL;

        for (int i = 0; i < n; i++) {
            scanf("%lld", &x);
            ans += mod_pow((x%mod+mod)%mod, k);
            if (ans >= mod) ans -= mod; 
        }

        printf("%lld\n", ans);
    }

    return 0;
}
 
  

 

 
 
 

转载于:https://www.cnblogs.com/Stomach-ache/p/3904074.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值