交换机 A 的配置:
vlan batch 20 30
#
interface Vlanif1
 ip address 192.168.1.1 255.255.255.0
#
interface Vlanif20
 ip address 192.168.20.1 255.255.255.0
#
interface Vlanif30
 ip address 192.168.30.1 255.255.255.0
 
interface Ethernet0/0/1
 port link-type access
 port default vlan 20
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 30
 
rip 1
 network 192.168.20.0
 network 192.168.30.0
 network 192.168.1.0
 
交换机的 B 配置
vlan batch 40
interface Vlanif1
 ip address 192.168.1.2 255.255.255.0
#
interface Vlanif40
 
network 192.168.1.0
network 192.168.40.0
 
在两个交换配之间端口做 trunk 配置,并允许所有的 vlan 通过
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094