Joseph(约瑟夫环)

Joseph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2094    Accepted Submission(s): 1273


Problem Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 

 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 

 

Output
The output file will consist of separate lines containing m corresponding to k in the input file.
 

 

Sample Input
3 4 0
 

 

Sample Output
5 30
题解:F(i)=(F(i-1)+m-1)%(n-i+1)由于去的后k个所以当F小于k就不符合。需要打表,否则超时;
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int k;
int dp[15];
bool solve(int m){
	int cur=0;
	for(int i=1;i<=k;i++){
		if((cur+m-1)%(2*k-i+1)<k)
			return false;
		cur=(cur+m-1)%(2*k-i+1);
	}
	return true;
}
int main(){
	for(k=1;k<15;k++){
		int i;
		for(i=1;;i++){
			if(solve(i))break;
		}
		dp[k]=i;
	}
	while(~scanf("%d",&k),k){
		printf("%d\n",dp[k]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,下面是一个基于循环链表的 Java 代码示例,可以实现约瑟夫环问题: ``` class Node { public int data; public Node next; public Node(int data) { this.data = data; } } class CircularLinkedList { private Node tail; public CircularLinkedList() { tail = null; } public void add(int data) { Node node = new Node(data); if (tail == null) { tail = node; tail.next = tail; } else { node.next = tail.next; tail.next = node; tail = node; } } public void remove(Node node) { if (node == tail) { tail = null; } else { Node prev = tail.next; while (prev.next != node) { prev = prev.next; } prev.next = node.next; } node.next = null; } public Node getHead() { return tail.next; } } public class Main { public static void main(String[] args) { int n = 10; // 总人数 int m = 3; // 数到 m 的人出圈 CircularLinkedList list = new CircularLinkedList(); for (int i = 1; i <= n; i++) { list.add(i); } Node head = list.getHead(); while (list.tail != null) { for (int i = 1; i < m; i++) { head = head.next; } System.out.print(head.data + " "); list.remove(head); head = head.next; } } } ``` 这段代码中,`CircularLinkedList` 类表示循环链表,`Node` 类表示链表中的节点。在 `add` 方法中,我们根据链表的特性,将新节点插入到链表尾部即可。在 `remove` 方法中,我们需要找到要删除的节点的前一个节点,然后将它从链表中删除即可。在 `getHead` 方法中,我们可以返回链表的头部节点。 在 `main` 方法中,我们首先将 1 到 10 这十个数依次加入到链表中。然后,每次数到 m 的人出圈,直到链表为空为止。在每次出圈之前,我们需要将链表中的节点依次遍历,直到找到要出圈的节点为止。出圈后,我们需要将指针指向下一个节点,继续进行后续的计数。 希望这段代码可以帮助你解决问题,如果你还有任何疑问,欢迎随时追问。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值