ZOJ3605-Find the Marble(可能性DP)

Find the Marble

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Alice and Bob are playing a game. This game is played with several identical pots and one marble. When the game starts, Alice puts the pots in one line and puts the marble in one of the pots. After that, Bob cannot see the inside of the pots. Then Alice makes a sequence of swappings and Bob guesses which pot the marble is in. In each of the swapping, Alice chooses two different pots and swaps their positions.

Unfortunately, Alice's actions are very fast, so Bob can only catch k ofm swappings and regard these k swappings as all actions Alice has performed. Now given the initial pot the marble is in, and the sequence of swappings, you are asked to calculate which pot Bob most possibly guesses. You can assume that Bob missed any of the swappings with equal possibility.

Input

There are several test cases in the input file. The first line of the input file contains an integerN (N ≈ 100), then N cases follow.

The first line of each test case contains 4 integers n, m, k and s(0 < sn ≤ 50, 0 ≤ km ≤ 50), which are the number of pots, the number of swappings Alice makes, the number of swappings Bob catches and index of the initial pot the marble is in. Pots are indexed from 1 to n. Then m lines follow, each of which contains two integersai and bi (1 ≤ ai, bi n), telling the two pots Alice swaps in the i-th swapping.

Outout

For each test case, output the pot that Bob most possibly guesses. If there is a tie, output the smallest one.

Sample Input
3
3 1 1 1
1 2
3 1 0 1
1 2
3 3 2 2
2 3
3 2
1 2
Sample Output
2
1
3
 
  
题目大意:N个容器,M次两两交换。当中K次是能够知道的,一開始珠子放在当中一个容器里。问你交换完以后,珠子在哪个容器的概率最大
 
  
思路:用DP[m][k][n] 表示 m次交换,知道了当中的k次,结尾为n的方案数
 
  
 
  
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using  namespace std;
typedef long long ll;
const  int maxn = 60;
int n,m,k,s;
int A[maxn],B[maxn];
ll dp[maxn][maxn][maxn];
int main(){

    int ncase;
    cin >> ncase;
    while(ncase--){
        scanf("%d%d%d%d",&n,&m,&k,&s);
        for(int i = 1; i <= m; i++){
            scanf("%d%d",&A[i],&B[i]);
        }
        memset(dp,0,sizeof dp);
        dp[0][0][s] = 1;
        for(int i = 1; i <= m; i++){
            dp[i][0][s] = 1;
            for(int j = 1; j <= i&&j <= k; j++){
                dp[i][j][A[i]] = dp[i-1][j-1][B[i]];
                dp[i][j][B[i]] = dp[i-1][j-1][A[i]];
                for(int d = 1; d <= n; d++){
                    dp[i][j][d] += dp[i-1][j][d];
                    if(d!=A[i]&&d!=B[i]){
                        dp[i][j][d] += dp[i-1][j-1][d];
                    }
                }
            }
        }
        int idx = 1;
        for(int i = 2; i <= n; i++){
            if(dp[m][k][i] > dp[m][k][idx]){
                idx = i;
            }
        }
        cout<<idx<<endl;
    }
    return 0;
}


 
  

版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值