Hdoj 2604

原题链接

描述

Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.

输入

Input a length L (0 <= L <= 10e6) and M.

输出

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

样例输入

3 8
4 7
4 8

样例输出

6
2
1

思路

首先是数学上找出递推关系式$ a_{n} = a_{n-1} + a_{n-3} + a_{n-4}, n > 4 $
接下来当然可以去解通项,不过略麻烦而且不好算,故直接构建矩阵,用矩阵快速幂。
\[ \left[ \begin{matrix} a_{n} & a_{n-1} & a_{n-2} & a_{n-3} \\ 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 \end{matrix} \right] = \left[ \begin{matrix} a_{n-1} & a_{n-2} & a_{n-3} & a_{n-4} \\ 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 \end{matrix} \right] \left[ \begin{matrix} 1 & 1 & 0 & 0 \\ 1 & 0 & 1 & 0 \\ 0 & 0 & 0 & 1 \\ 1 & 0 & 0 & 0 \end{matrix} \right] \]

代码

#include <cstdio>
#include<cstring>
#define ll long long
#define maxn 4
using namespace std;

int k, mod;

struct Mat
{
    ll f[maxn][maxn];
    void cls(){memset(f, 0, sizeof(f));}//全部置为0 
    Mat() {cls();}
    friend Mat operator * (Mat a, Mat b)
    {
        Mat res;
        for(int i = 0; i < maxn; i++) for(int j = 0; j < maxn; j++)
            for(int k = 0; k < maxn; k++)
                (res.f[i][j] += a.f[i][k] * b.f[k][j]) %= mod;
        return res;
    }
};

Mat quick_pow(Mat a)  
{  
    Mat ans;
    for(int i = 0; i < maxn; i++) ans.f[i][i] = 1;
    int b = k;
    while(b != 0)  
    {
        if(b & 1) ans = ans * a;
        b >>= 1;
        a = a * a;
    }
    return ans;  
}

int main()
{
    Mat A, B;
    B.f[0][0] = 9; B.f[0][1] = 6; B.f[0][2] = 4; B.f[0][3] = 2;
    A.f[0][0] = A.f[0][1] = A.f[1][2] = A.f[2][0] = A.f[2][3] = A.f[3][0] = 1;
    while(~scanf("%d %d", &k, &mod))
    {
        Mat C;
        if(k <= 4) {printf("%d\n", B.f[0][4-k] % mod); continue;}
        k -= 4;
        C = quick_pow(A);
        C = B * C;
        printf("%d\n", C.f[0][0]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/HackHarry/p/8391899.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值