参考配置:

(1)

Router1>

Router1>en

Router1#show running
Building configuration...
 
Current configuration : 612 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
 
interface FastEthernet0/0
 ip address 192.168.10.254 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0
 ip address 192.168.20.10 255.255.255.0
!
interface Serial0/1
 no ip address
 shutdown
!
router rip
 network 192.168.10.0
 network 192.168.20.0
 
(2)
Router2>
Router2>en
Route2r#show running
Building configuration...
 
Current configuration : 806 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router2
!
interface FastEthernet0/0
 ip address 192.168.40.254 255.255.255.0
 ip access-group 1 out
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0
 no ip address
 shutdown
!
interface Serial0/1
 ip address 192.168.30.10 255.255.255.0
 ip access-group 2 out
 clock rate 64000
!
router rip
 network 192.168.30.0
 network 192.168.40.0
!
ip classless
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 deny any
access-list 2 deny host 192.168.40.11
access-list 2 permit any
 
(3)
Router0>en
Router0#show running
Building configuration...
 
Current configuration : 629 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0
 ip address 192.168.20.11 255.255.255.0
 clock rate 64000
!
interface Serial0/1
 ip address 192.168.30.11 255.255.255.0
!
router rip
 network 192.168.20.0
 network 192.168.30.0