r1:

!        
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!        
interface Serial0/0
 ip address 12.1.1.1 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!        
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 network 12.1.1.0 mask 255.255.255.0
 neighbor 12.1.1.2 remote-as 1
 neighbor 12.1.1.2 next-hop-self
 no auto-summary

 

r2:

!        
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!        
interface Serial0/0
 ip address 12.1.1.2 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/1
 ip address 23.1.1.2 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!        
router ospf 110
 log-adjacency-changes
 network 2.2.2.0 0.0.0.255 area 0
 network 23.1.1.0 0.0.0.255 area 0
!        
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 network 12.1.1.0 mask 255.255.255.0
 network 23.1.1.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 4.4.4.4 remote-as 1
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 4.4.4.4 next-hop-self
 neighbor 12.1.1.1 remote-as 2
 neighbor 12.1.1.1 next-hop-self
 no auto-summary
!        
no ip http server
no ip http secure-server
!        

 

r3:

!        
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!        
interface Serial0/0
 ip address 23.1.1.3 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/1
 ip address 34.1.1.3 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!        
router ospf 119
 log-adjacency-changes
!        
router ospf 110
 log-adjacency-changes
 network 3.3.3.0 0.0.0.255 area 0
 network 23.1.1.0 0.0.0.255 area 0
 network 34.1.1.0 0.0.0.255 area 0
 network 35.1.1.0 0.0.0.255 area 0
!        
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 network 23.1.1.0 mask 255.255.255.0
 network 34.1.1.0 mask 255.255.255.0
 network 35.1.1.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 next-hop-self
 neighbor 4.4.4.4 remote-as 1
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 4.4.4.4 next-hop-self
 no auto-summary
!        
no ip http server
no ip http secure-server
!        
!        

r4:

interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!        
interface Serial0/0
 ip address 34.1.1.4 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/1
 ip address 45.1.1.4 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!        
router ospf 110
 log-adjacency-changes
 network 4.4.4.0 0.0.0.255 area 0
 network 34.1.1.0 0.0.0.255 area 0
 network 45.1.1.0 0.0.0.255 area 0
!        
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 network 34.1.1.0 mask 255.255.255.0
 network 45.1.1.0 mask 255.255.255.0
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 45.1.1.5 remote-as 3
 neighbor 45.1.1.5 next-hop-self
 no auto-summary
!        
no ip http server
no ip http secure-server

 

r5:

interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!        
interface Serial0/0
 ip address 45.1.1.5 255.255.255.0
 serial restart-delay 0
 clock rate 9600
!        
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!        
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!        
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 5.5.5.0 mask 255.255.255.0
 network 45.1.1.0 mask 255.255.255.0
 neighbor 45.1.1.4 remote-as 1
 neighbor 45.1.1.4 next-hop-self
 no auto-summary
!        
no ip http server
no ip http secure-server