【1500】Message Flood (SDUTOJ)

Message Flood

Time Limit: 1500ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

示例输出

3
 
  
 
  
 
  
本题的意思是,先输入n个其朋友的名字,再输入m个给他发过短信的朋友的名字,输出 没给他发过短信的朋友 的个数。
本题应注意:发给他短信的人不一定在他的朋友名单里,而且一个朋友可以给他发多次短信。
 
  
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    int flag;
    struct node *next[26];
};
struct node *creat()//建立新的节点
{
    struct node *p;
    p=(struct node *)malloc(sizeof(struct node));
    for(int i=0;i<26;i++)
        p->next[i]=NULL;
    p->flag=0;
    return p;
};
void inser(struct node *head,char *str)//插入法建立字典树
{
    int len,i,t;
    struct node *p;
    p=head;
    len=strlen(str);
    for(i=0;i<len;i++)
    {
        if(str[i]>='A'&&str[i]<='Z')//不区分大小写
          t=str[i]-'A';
        else
          t=str[i]-'a';
        if(p->next[t]==NULL)
            p->next[t]=creat();
        p=p->next[t];
    }
    p->flag=1;
}
int find(struct node *head,char *str)//查找
{
    struct node *p;
    p=head;
    int i,t;
    int n=strlen(str);
    for(i=0;i<n;i++)
    {
        if(str[i]>='A'&&str[i]<='Z')
          t=str[i]-'A';
        else
          t=str[i]-'a';
        if(p->next[t]==NULL)
            return 0;
        else
            p=p->next[t];
    }
    if(p->flag==1)
        return 1;
    return 0;
}
int main()
{
    struct node *head;
    int n,m,i,num;
    char name[30000][20],s[100000];
    while(scanf("%d",&n),n)
    {
        num=0;//num为给他发过短信的朋友的个数
        head=creat();
        scanf("%d%*c",&m);
        for(i=0;i<n;i++)
            scanf("%s",name[i]);
        for(i=0;i<m;i++)
        {
            scanf("%s",s);
            inser(head,s);
        }
        for(i=0;i<n;i++)
        {
            if(find(head,name[i])!=1)
                num++;
        }
        printf("%d\n",num);
    }
    return 0;
}
 

转载于:https://www.cnblogs.com/jiangyongy/p/3971659.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值