1063 Set Similarity (25 分)(set)

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10^​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意:

给出 N (≤50) 个集合,给出的集合中可能含有相同的值。然后要求 M(≤10^​4​​) 个查询,每个查询给出两个集合的编号 X 和 Y,求集合 X 和集合 Y 的相同元素率,即两个集合的交集与并集(均需去重)的元素的比率

输出结果保留一位小数

知识点:

set

  1. 添加 #include <set> 以及 using namespace std;
  2. 定义:set<typename> name;
  3. set 数组的定义和 vector 相同: set<typename> Arrayname[arraysize], 比如 set<int> a[100];
  4. set 中元素的访问只能通过迭代器来访问 set<typename>::iterator it; 例如在 for 循环中的使用 for(set<int>::iterator it = a[x].begin(); it != a[x].end(); it++)
  5. insert(x) 将 x 插入容器 set 中,并且自动递增排序和去重
  6. fine(value) 返回 set 中对应值为 value 的迭代器,判断是否找到 st[y].find(*it) != st[y].end()
  7. size() 获取 set 中元素个数 

思路:

  1. 读入元素时,将数据存入 set 中可以去重
  2. 对于每一个查询(查询集合 x 与集合 y 的情况),设置变量 totalNum (初值设为 y 的元素个数)与 sameNum (初值为0),枚举集合 x 中的元素,判断其是否在集合 y 中出现过(采用 find 方法) 

注意:

  1. 输出 % 时要注意 printf("%.1f%%\n", sameNum * 100.0 / totalNum); 转义符; 保留一位小数
#include <cstdio>
#include <set>
using namespace std;
const int N = 51;
set<int> st[N];
void compare(int x, int y){
  int totalNum = st[y].size(), sameNum = 0;
  for(set<int>::iterator it = st[x].begin(); it != st[x].end(); it++){
    if(st[y].find(*it) != st[y].end())
      sameNum++;
    else
      totalNum++;
  }
  printf("%.1f%%\n", sameNum * 100.0 / totalNum);
}
int main(){
  int n, k, q, v, st1, st2;
  scanf("%d", &n);
  for(int i = 1; i <= n; i++){
    scanf("%d", &k);
    for(int j = 0; j < k; j++){
      scanf("%d", &v);
      st[i].insert(v);
    }
  }
  scanf("%d", &q);
  for(int i = 0; i < q; i++){
    scanf("%d %d", &st1, &st2);
    compare(st1, st2);
  }
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值