A1013 Battle Over Cities (25 分)(删除图的一个节点需要添加几条边连通)(图的DFS)(邻接表存储)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题意:

 给定无向图,规定当删除图中某个顶点时,同时删除与其连接的边。接下来给出K此查询,每个查询给出一个预删除的顶点编号,求删除该顶点后需要增加多少条边,才能使图连通

思路:

  1. 删除顶点?这个不用真的删除,只是在访问到该顶点时,返回即可
  2. 增加边数?当前图中连通块的个数减1
  3. 连通块个数?DFS全部节点的次数

知识点:

图的遍历:

  1. 存储结构为领接表时,只存放每条边的终点编号,不存放边权,因而采用vector即可:vector<int> Adj[N]; 其中Adj[1] 中存储从1号结点出发,到其他节点的路径终点
  2. 1号到3号之间有边,则 Adj[1].push_back(3);

memset函数

  1. 用来对一段内存空间全部设置为某个字符,一般用在对定义的字符串进行初始化为‘ ’或‘/0’;
  2. 例:char a[100];memset(a, '/0', sizeof(a));
  3. 本题中对vis数组进行初始化:memset(vis, false, sizeof(vis)); 相当于for(int i = 0; i < N; i++){ vis[i] = false; }
  4. #include <cstring>

注意:

  1. 对于无向图,在读入数据时,需要将两个方向的边都进行存储
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int N = 1111;
vector<int> G[N];       //领接表
bool vis[N];

int currentPoint;       //当前需要删除的顶点编号
void dfs(int v){
    if(v == currentPoint)   //当遍历到已删除节点时,返回
        return;
    vis[v] = true;
    for(int i = 0; i < G[v].size(); i++){
        if(vis[G[v][i]] == false){
            dfs(G[v][i]);
        }
    }
}
int n, m, k;
int main(){
    scanf("%d%d%d", &n, &m, &k);    //顶点数、边数、查询数
    for(int i = 0; i < m; i++){
        int a, b;
        scanf("%d%d", &a, &b);
        G[a].push_back(b);
        G[b].push_back(a);
    }
    for(int query = 0; query < k; query++){
        scanf("%d", &currentPoint);
        for(int i = 0; i < N; i++){
            vis[i] = false;
        }
        int block = 0;      //连通块个数
        for(int i = 1; i <= n; i++){
            if(i != currentPoint && vis[i] == false){   //如果未被删除且未被访问
                dfs(i);
                block++;
            }
        }
        printf("%d\n", block - 1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值