POJ - 2185 Milking Grid















Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.

Input
* Line 1: Two space-separated integers: R and C

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character.
Output
* Line 1: The area of the smallest unit from which the grid is formed
Sample Input
2 5
ABABA
ABABA
Sample Output
2
Hint
The entire milking grid can be constructed from repetitions of the pattern 'AB'.


题意:

求最小的可覆盖的矩形面积


思路:

求出行的最大循环块长度,则另一个变量为此值,若长度超过列宽则等于列宽

再求出列的最大循环块长度,也令一个变量做上述处理。

最后矩形的面积即为两者乘积


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
#include<cmath>
using namespace std;

#define INF 0x3f3f3f3f

int n,m;
string s[10005];
int nex[10005];

int get_next(string b){
	int m=b.size();
	int i=0,j=-1;
	nex[0]=-1;
	while(i<m){
		if(j==-1 || b[i]==b[j])nex[++i]=++j;
		else j=nex[j];
	}
	
	return m-nex[m];
}

int main(){
	while(~scanf("%d%d",&n,&m)){
		int a=-INF,b=-INF;
		for(int i=0;i<n;i++){
			cin>>s[i];
			a=max(a,get_next(s[i]));
		}
		if(a>m)a=m;
		
		for(int i=0;i<m;i++){
			string t="";
			for(int j=0;j<n;j++)
				t+=s[j][i];
			b=max(b,get_next(t));
		}
		if(b>n)b=n;
		
		printf("%d\n",a*b);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值