1138. Postorder Traversal (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
Sample Output:

3

tips:

 (1)根据先序确定当前树的根,利用根与中序,划分该根左子树与右子树部分,不断递归建树

 (2)后序遍历,输出第一个数即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=50010;
int pre[maxn],in[maxn];
struct node{
	int v;
	node *lchild,*rchild;
};
void create(node* &root,int preL,int preR,int inL,int inR)
{
	if(preL>preR)return;
	root=new node;
	root->v=pre[preL];
	root->lchild=root->rchild=NULL;
	int left=0,k;
	for(k=inL;k<inR;k++)
	{
		if(in[k]==pre[preL])break;
		left++;
	}
	create(root->lchild,preL+1,preL+left,inL,k-1);
	create(root->rchild,preL+left+1,preR,k+1,inR);
}
int k=0;
void postorder(node* root)
{
	if(root==NULL)return;
	postorder(root->lchild);
	postorder(root->rchild);
	if(k==0)printf("%d\n",root->v);
    k++;
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&pre[i]);
	}
	for(int i=0;i<n;i++)
	{
		scanf("%d",&in[i]);
	}
	node *root=NULL;
	create(root,0,n-1,0,n-1);
	postorder(root);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值