Cutting an integer means to cut a K digits long integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 x 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<= 20). Then N lines follow, each gives an integer Z (10<=Z<=231). It is guaranteed that the number of digits of Z is an even number.
Output Specification:
For each case, print a single line "Yes" if it is such a number, or "No" if not.
Sample Input:3 167334 2333 12345678Sample Output:
Yes No No
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
int z,a,b,t;
int k=0;
scanf("%d",&z);
t=z;
while(t)
{
k++;
t/=10;
}
int p=pow(10,k/2);
a=z/p;
b=z%p;
if(a*b!=0&&z%(a*b)==0)printf("Yes\n");
else printf("No\n");
}
return 0;
}