POJ 1491 Pi

Pi
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4977 Accepted: 2775

Description

Professor Robert A. J. Matthews of the Applied Mathematics and Computer Science Department at the University of Aston in Birmingham, England has recently described howthe positions of stars across the night skymay be used to deduce a surprisingly accurate value of π. This result followed from the application of certain theorems in number theory. 
Here, we don't have the night sky, but can use the same theoretical basis to form an estimate for π: 

Given any pair of whole numbers chosen from a large, random collection of numbers, the probability that the twonumbers have no common factor other than one (1) is 

6/π 2


For example, using the small collection of numbers: 2, 3, 4, 5, 6; there are 10 pairs that can be formed: (2,3), (2,4), etc. Six of the 10 pairs: (2,3), (2,5), (3,4), (3,5), (4,5) and (5,6) have no common factor other than one. Using the ratio of the counts as the probability we have: 

6/π 2 ≈ 6/10 
π ≈ 3.162


In this problem, you'll receive a series of data sets. Each data set contains a set of pseudo-random positive integers. For each data set, find the portion of the pairs which may be formed that have nocommon factor other than one (1), and use the method illustrated above to obtain an estimate for π. Report this estimate for each data set. 

Input

The input consists of a series of data sets. 

The first line of each data set contains a positive integer value, N, greater than one (1) and less than 50. 

There is one positive integer per line for the next N lines that constitute the set for which the pairs are to be examined. These integers are each greater than 0 and less than 32768. 

Each integer of the input stream has its first digit as the first character on the input line. 

The set size designator, N, will be zero to indicate the end of data. 

Output

A line with a single real value is to be emitted for each input data set encountered. This value is the estimate π for the data set. An output format like the sample below should be used. Answers must be rounded to six digits after the decimal point. 

For some data sets, it may be impossible to estimate a value for π. This occurs when there are no pairs without common factors. In these cases, emit the single-line message: 

No estimate for this data set. 

exactly, starting with the first character, "N", as the first character on the line. 

Sample Input

5
2
3
4
5
6
2
13
39
0

Sample Output

3.162278
No estimate for this data set.
//利用公式6/(PI*PI)=count/sum 计算出PI的值  不过要注意对没有约数的数对进行计数,可以利用最大公约数返回1
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <string>

using namespace std;
int num[500];
int gcd(int a, int b){//如果没有公约数的话返回1;
    if(a==0)
        return b;
    if(b==0)
        return a;
    if(a>b) return gcd(b,a%b);
    return gcd(a,b%a);
}
int main(int argc, char const *argv[])
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        int count=0,sum=0;
        for (int i = 0; i < n; ++i)
            scanf("%d",&num[i]);
        for(int i=1;i<n;i++)
            sum+=i;
        for(int i=0;i<n-1;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                
                if(gcd(num[i],num[j])==1)//计算非公约数的数值
                    count++;
            }
        }
        if(count==0)
            cout<<"No estimate for this data set."<<endl;
        else
        {
            double p=sqrt((double)sum*6/(double)count);
            printf("%.6f\n",p);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值