HDU1004

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 120896    Accepted Submission(s): 47475


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
//找出输入的字符序列中重复次数最多的(题目保证每一个测试案例只有一个是最多的) //利用sort 对字符序列排序,之用整型数组进行同步计数
#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

int main()
{
    string s[1001];
    int n;
    while(cin>>n&&n)
    {
        for(int i=0;i<n; ++i)
            cin>>s[i];
        sort(s,s+n);//字符串排序,将相同的字符串放在一起
        int sum[1001];
        for(int i=0;i<n;i++)
            sum[i]=1;
        int max=0;
        sum[max]=1;
        int i;
        for(i=1;i<n;i++)
        {
            if(s[i]==s[i-1])//利用整型数组进行同步计数
                sum[i]+=sum[i-1];
            if(sum[i]>sum[max])
                max=i;
        }
        cout<<s[max]<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值