HDU4324 拓扑排序

Triangle LOVE


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2683    Accepted Submission(s): 1084

Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
 
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
 
Sample Output
Case #1: Yes

Case #2: No


题目意思是每两个人之间一定存在一条有向边,即u->v,但不存在双向边,求一个三元环,即a->b->c->a。

因为每两个人之间一定存在一条有向边,那么只要存在环,肯定就有三元环。

使用拓扑排序判断是否有环。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <queue>
#include <map>

using namespace std;
const int maxn = 2e3+10;
const int mod = 2e9 + 7;
typedef long long ll;
typedef unsigned long long ull;

int n, k = 1;
int c[maxn],a[maxn][maxn];
char s[maxn][maxn];

bool dfs(int u)
{
    c[u] = -1;
    for(int v = 1; v <= n; v++){
        if(a[u][v]){
            if(c[v] < 0) return false;
            else if(!c[v] && !dfs(v)) return false;
        }
    }
    c[u] = 1;
    return true;
}

bool toposort()
{
    memset(c,0,sizeof(c));
    for(int u = 1; u <= n; u++){
        if(!c[u]){
            if(!dfs(u))
                return false;
        }
    }
    return true;
}

void work()
{
    scanf("%d",&n);
    getchar();
    for(int i = 1; i <= n; i++){
        scanf("%s",s[i] + 1);
    }
    for(int i = 1; i <= n; i++){
        for(int j = 1; j <= n; j++){
            if(s[i][j] == '1'){
                a[i][j] = 1;
            }
            else a[i][j] = 0;
        }
    }
    if(!toposort())
        printf("Case #%d: Yes\n",k++);
    else printf("Case #%d: No\n",k++);
}

int main()
{
#ifdef LOCAL
    freopen("case.in","r",stdin);
    // freopen("case.out","w",stdout);
#endif
    int t;
    cin>>t;
    while(t--)
        work();
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值