CF1468J Road Reform 题解

文章讲述了如何在给定的带权重无向图中,通过拆掉部分边形成一棵树,并对剩余边进行最少次数的操作,使得所有边的最大速度限制等于给定的目标值k。方法涉及使用Kruskal算法构建最小生成树,然后根据边权与k的关系进行分类讨论和操作计算。
摘要由CSDN通过智能技术生成

CF1468J Road Reform 题解

link

CF1468J Road Reform

题面翻译

给定一个有 n n n 个节点, m m m 条无向带权边的图,和一个参数 k k k,第 i i i 条边权值为 s i s_i si

现在你要保留这个图中的 n − 1 n-1 n1 条边使得这个图变成一棵树,然后你可以对这棵树上的任意边进行修改,每次修改可以使这个边的权值加上一或减去一。

现在你需要使所有边权的最大值正好等于 k k k,求所有保留方案的最小操作数。

T T T 组询问。

保证初始时给定的图满足任意两个点互相可达,没有重边或自环。

1 ≤ T ≤ 1 0 3 . 1\leq T\leq 10^3. 1T103.

1 ≤ n ≤ 2 × 1 0 5 ; n − 1 ≤ m ≤ min ⁡ ( n ( n + 1 ) 2 , 2 × 1 0 5 ) ; 1\leq n\leq2\times10^5;n-1\leq m\leq \min(\frac{n(n+1)}{2},2\times10^5); 1n2×105;n1mmin(2n(n+1),2×105);

∑ n , ∑ m ≤ 2 × 1 0 5 ; \sum n,\sum m\leq2\times10^5; n,m2×105;

1 ≤ k , s i ≤ 1 0 9 . 1\leq k,s_i\leq 10^9. 1k,si109.

题目描述

There are n n n cities and m m m bidirectional roads in Berland. The i i i -th road connects the cities x i x_i xi and y i y_i yi , and has the speed limit s i s_i si . The road network allows everyone to get from any city to any other city.

The Berland Transport Ministry is planning a road reform.

First of all, maintaining all m m m roads is too costly, so m − ( n − 1 ) m - (n - 1) m(n1) roads will be demolished in such a way that the remaining ( n − 1 ) (n - 1) (n1) roads still allow to get to any city from any other city. Formally, the remaining roads should represent an undirected tree.

Secondly, the speed limits on the remaining roads might be changed. The changes will be done sequentially, each change is either increasing the speed limit on some road by 1 1 1 , or decreasing it by 1 1 1 . Since changing the speed limit requires a lot of work, the Ministry wants to minimize the number of changes.

The goal of the Ministry is to have a road network of ( n − 1 ) (n - 1) (n1) roads with the maximum speed limit over all roads equal to exactly k k k . They assigned you the task of calculating the minimum number of speed limit changes they have to perform so the road network meets their requirements.

For example, suppose the initial map of Berland looks like that, and k = 7 k = 7 k=7 :

Then one of the optimal courses of action is to demolish the roads 1 1 1 4 4 4 and 3 3 3 4 4 4 , and then decrease the speed limit on the road 2 2 2 3 3 3 by 1 1 1 , so the resulting road network looks like that:

输入格式

The first line contains one integer t t t ( 1 ≤ t ≤ 1000 1 \le t \le 1000 1t1000 ) — the number of test cases.

The first line of each test case contains three integers n n n , m m m and k k k ( 2 ≤ n ≤ 2 ⋅ 1 0 5 2 \le n \le 2 \cdot 10^5 2n2105 ; n − 1 ≤ m ≤ min ⁡ ( 2 ⋅ 1 0 5 , n ( n − 1 ) 2 ) n - 1 \le m \le \min(2 \cdot 10^5, \frac{n(n-1)}{2}) n1mmin(2105,2n(n1)) ; 1 ≤ k ≤ 1 0 9 1 \le k \le 10^9 1k109 ) — the number of cities, the number of roads and the required maximum speed limit, respectively.

Then $ m $ lines follow. The $ i $ -th line contains three integers x i x_i xi , y i y_i yi and s i s_i si ( 1 ≤ x i , y i ≤ n 1 \le x_i, y_i \le n 1xi,yin ; x i ≠ y i x_i \ne y_i xi=yi ; 1 ≤ s i ≤ 1 0 9 1 \le s_i \le 10^9 1si109 ) — the cities connected by the i i i -th road and the speed limit on it, respectively. All roads are bidirectional.

The road network in each test case is connected (that is, it is possible to reach any city from any other city by traveling along the road), and each pair of cities is connected by at most one road.

The sum of $ n $ over all test cases does not exceed 2 ⋅ 1 0 5 2 \cdot 10^5 2105 . Similarly, the sum of m m m over all test cases does not exceed 2 ⋅ 1 0 5 2 \cdot 10^5 2105 .

输出格式

For each test case, print one integer — the minimum number of changes the Ministry has to perform so that the maximum speed limit among the remaining ( n − 1 ) (n - 1) (n1) roads is exactly k k k .

样例 #1

样例输入 #1

4
4 5 7
4 1 3
1 2 5
2 3 8
2 4 1
3 4 4
4 6 5
1 2 1
1 3 1
1 4 2
2 4 1
4 3 1
3 2 1
3 2 10
1 2 8
1 3 10
5 5 15
1 2 17
3 1 15
2 3 10
1 4 14
2 5 8

样例输出 #1

1
3
0
0

提示

The explanation for the example test:

The first test case is described in the problem statement.

In the second test case, the road network initially looks like that:

The Ministry can demolish the roads 1 1 1 2 2 2 , 3 3 3 2 2 2 and 3 3 3 4 4 4 , and then increase the speed limit on the road 1 1 1 4 4 4 three times.

In the third test case, the road network already meets all the requirements.

In the fourth test case, it is enough to demolish the road 1 1 1 2 2 2 so the resulting road network meets the requirements.

算法:最小生成树

思路:
首先看题。

题目中说:要在图中保留 n − 1 n−1 n1 条边,使它变成一棵树。

因此想到 最小生成树。

我这里用的是 Kruskal,需要用到并查集。

因此要注意并查集要初始化!

大家应该都知道 Kruskal 算法的流程是:先对边权从小到大排序,再枚举每一个 i i i,看一下所对应的 u u u v v v 是否在同一个集合内。如果不是,就可以选择这一条边。

做完最小生成树以后,我们要进行分类讨论:

计最小生成树中最大的边权为 t t t

t < k t<k t<k 时,遍历所有边,取与 k k k 差值最小的即可。

t > k t>k t>k 时,将所有边权与 k k k 的差值相加即可。

注意多测要清空即可。

代码:

#include<bits/stdc++.h>
using namespace std;
#define ll long long
const ll N=4e5+10,inf=2e9;
ll T,n,m,k,t,ans,ct,fa[N];
struct E{
    ll u,v,w;
}a[N];
bool cmp(E l,E r){
    return l.w<r.w;
}
void jian(){
    for(int i=1;i<=n;i++) fa[i]=i;
}
ll getfa(ll x){
    return fa[x]==x?x:fa[x]=getfa(fa[x]);
}
void kruskal(){
    jian();ct=t=ans=0;//多测不清空,爆零两行泪!
    sort(a+1,a+m+1,cmp);
    for(int i=1;i<=m;i++){
        ll x=getfa(a[i].u),y=getfa(a[i].v);
        if(x==y) continue;
        t=a[i].w,ans+=max(t-k,0ll),fa[x]=y;
        //因为边权是从小到大枚举的,所以当前值一定是最大的
    }
}
int main(){
    ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
    cin>>T;
    while(T--){
        cin>>n>>m>>k;
        for(int i=1;i<=m;i++)
            cin>>a[i].u>>a[i].v>>a[i].w;
        kruskal();
        if(t<k){
            ans=inf;//不要忘记
            for(int i=1;i<=m;i++)
                ans=min(ans,abs(a[i].w-k));
        }//t>k的情况在做最小生成树的时候顺便求出来了
        cout<<ans<<"\n";
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值