Appium+python自动化18-brew、carthage和appium-doctor

前言

本篇安装brew、carthage,解决启动appium时的报错问题,另外安装appium-doctor检查appium的环境

1.brew

2.carthage

3.appium-doctor

 

一、brew安装

1.brew是一个软件包管理工具,类似于centos下的yum或者ubuntu下的apt-get,类似于python之pip或java之maven,就是这么回事。

2.brew的安装是需要用ruby安装的,ruby这玩意mac自带了,终端输入:ruby -v 可查看版本号

3.继续输入这个这个指令安装brew:ruby -e "$(curl --insecure -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

$ ruby -v

$ ruby -e "$(curl --insecure -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

4.安装完成后查看版本号

$ brew -v

4.卸载指令:

$ ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/uninstall)"

 

二、carthage

1.直接用上一步安装的brew去安装carthage

$ brew install carthage

 

三、appium-doctor

1.用之前安装cnpm去安装appium-doctor,先确定版本号

$ cnpm -v

$ cnpm install appium-doctor

2.用appium-doctor去检查appium的环境,这个之前玩过windows上的appium环境应该都熟悉

$ appium-doctor -v

$ appium-doctor

3.上图除了红色框框区域,上面的显示√才是正常的,显示X就得想办法解决了。

上图红色框框区域都是一些android的环境,显示X也没关系,要是不打算再mac上安装android环境可以暂时不用管。

展开阅读全文

没有更多推荐了,返回首页