Labeling Balls(POJ 3687-逆序拓扑排序)

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14900 Accepted: 4368

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains(驱使) like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

POJ Founder Monthly Contest – 2008.08.31, windy7926778

一个给球标上标签,好让大家知道这个球是第几重的悲伤的故事。
#include <stdio.h>  
#include <string.h>  
#include <stdlib.h>  
#include <iostream>  
#include <algorithm>  
#include <queue>  
#include <set>  
using namespace std;
int map[210][210];//邻接矩阵存有向图
int out[210];//出度
void topo(int n)//逆序的拓扑排序
{
	int i;
	int cnt = n;
	int weight[210];
	priority_queue<int >q;//优先队列,按照从大到小排序(以便输出时按字典序输出)
	for (i = 1; i <= n; i++) {
		if (out[i] == 0)
			q.push(i);
	}
	while (!q.empty()) {
		int k = q.top();
		q.pop();
		weight[k] = cnt--;
		for (i = 1; i <= n; i++) {
			if (map[i][k]) {
				out[i]--;
				if (out[i] == 0)//出度为零时加入队列
					q.push(i);
			}
		}
	}
	if (cnt>0)//存在环
		printf("-1\n");
	else {
		for (i = 1; i<n; i++)//输出自己是第几重
			printf("%d ", weight[i]);
		printf("%d\n", weight[i]);
	}
}
int main()
{
	int T, n, m;
	int a, b;
	scanf("%d", &T);
	while (T--) {
		scanf("%d %d", &n, &m);
		memset(out, 0, sizeof(out));
		memset(map, 0, sizeof(map));
		while (m--) {
			scanf("%d %d", &a, &b);
			if (map[a][b] == 0) {//注意重边
				map[a][b] = 1;
				out[a]++;
			}
		}
		topo(n);
	}
	return 0;
}

转载地址:http://blog.csdn.net/u013486414/article/details/42616073
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值