max sum 1003 java,杭电1003——Max Sum(Java实现)

Max Sum

ime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 353641 Accepted Submission(s): 84455

Problem Description

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6

e0e137f00feb4a50f86f53908a962772.png

思路:

这道题看着挺难,其实也没什么玄机;主要是搞清楚一个概念即可:

如果前面的数是非负数,累加后面的数一定比后面的数本身大

如果前面的数是负数,即需要移动起始位置,寻找后面的数

import java.util.Scanner;

public class Main {

public static void main(String[] args) {

Scanner sc=new Scanner(System.in);

int n=sc.nextInt();

int S=1;//输出需要;

while(n>0){

int k=sc.nextInt();

int [] sum=new int [k+1];

for (int i = 0; i

sum[i]=sc.nextInt();

}

int [] Text=new int[]{-10001,1,1};//范围在-1000到1000中;

int Max=0,next=1;

//Max中暂时存放当前最大的和;

//next中存放序列的截至位置

for (int i = 0; i

Max+=sum[i];

if (Max>Text[0]){

Text[0]=Max; //Text[0]中存放最大的和;

Text[1]=next;//Text[1]存放产生最大数的序列的起始位置

Text[2]=i+1;//Text[2]存放产生最大数的序列的终止位置

}

if (Max<0){//如果前面的数之和为负数,则改变起始位置,Max置零;

next=i+2;

Max=0;

}

}

System.out.printf("Case %d:%n",S++);

System.out.println(Text[0]+" "+Text[1]+" "+Text[2]);

n--;

if (n!=0)System.out.println();

}

}

总结:这是杭电oj的基础题,相较于我们学校的oj…你不服不行;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值