Solaris11自带php配置,solaris11网络相关配置

By 2018-12-27

1、首先的确定solaris的NCP是否为手动配置模式

Automatic 自动

DefaultFixed 手动

root@sol-11:~# netadm list

TYPE PROFILE STATE

ncp Automatic disabled

ncp DefaultFixed online

loc Automatic offline

loc NoNet offline

loc DefaultFixed online

2、NCP从自动网络配置模式转换为手动配置模式

root@sol-11:~# netadm enable -p ncp DefaultFixed

3、如果出现下列情况,说明已经是手动状态

root@sol-11:~# netadm: DefaultFixed NCP is enabled;

root@sol-11:~# automatic network management is not available.

root@sol-11:~# netadm list' is only supported when automatic network management is active.

4、确认要配置的接口

root@sol-11:~# dladm show-phys

LINK MEDIA STATE SPEED DUPLEX DEVICE

net0 Ethernet up 1000 full e1000g0

5、创建net0,配置net0的IP v4地址,查看地址是否生效

root@sol-11:~# ipadm create-ip net0

root@sol-11:~# ipadm create-addr -T static -a 192.168.1.100/24 net0/v4

root@sol-11:~# ipadm show-addr

ADDROBJ TYPE STATE ADDR

lo0/v4 static ok 127.0.0.1/8

net0/v4 static ok 192.168.1.100/24

lo0/v6 static ok ::1/128

删除ip地址

root@sol-11:~# ipadm delte-addr net0/v4

6、配置,并查看网关

root@sol-11:~# route -p add default 192.168.1.1

root@sol-11:~# netstat -rn

Routing Table: IPv4

Destination Gateway Flags Ref Use Interface

-------------------- -------------------- ----- ----- ---------- ---------

default 192.168.1.1 UG 2 1474

127.0.0.1 127.0.0.1 UH 2 40 lo0

192.168.0.0 192.168.1.100 U 5 1815 net0

Routing Table: IPv6

Destination/Mask Gateway Flags Ref Use If

--------------------------- --------------------------- ----- --- ------- -----

::1 ::1 UH 2 4 lo0

7、配置DNS

root@sol-11:~# svccfg -s dns/client

svc:/network/dns/client> setprop config/nameserver = (8.8.8.8 8.8.4.4)

svc:/network/dns/client> listprop config

config application

config/value_authorization astring solaris.smf.value.name-service.dns.client

config/nameserver net_address 8.8.8.8 8.8.4.4

svc:/network/dns/client> exit

root@sol-11:~# svcadm refresh dns/client

root@sol-11:~# svcadm restart dns/client

检查

root@sol-11:~# more /etc/resolv.conf

#

# _AUTOGENERATED_FROM_SMF_V1_

#

# WARNING: THIS FILE GENERATED FROM SMF DATA.

# DO NOT EDIT THIS FILE. EDITS WILL BE LOST.

# See resolv.conf(4) for details.

nameserver 8.8.8.8

nameserver 8.8.4.4

如果不存在resolv.conf文件,则:

#svcs dns/client

如果出现disabled Jul_11 svc:/network/dns/client:default

执行#svcadm enable dns/client 开启这个功能

若出现如下错误:

svc:/network/dns/client> setprop config/nameserver = (8.8.8.8 8.8.4.4)

Multiple string values or string values with spaces must be quoted with '"'.

使用该方式进行更改:

setprop config/nameserver=net_address: 8.8.8.8

setprop config/nameserver = (8.8.8.8 8.8.4.4)

删除search localdomain:

svc:/network/dns/client> delprop config/search

8、配置name-server

root@sol-11:~# svccfg -s name-service/switch

svc:/system/name-service/switch> setprop config/host = "files dns"

svc:/system/name-service/switch> listprop config

config application

config/default astring files

config/value_authorization astring solaris.smf.value.name-service.switch

config/printer astring "user files"

config/host astring "files dns"

svc:/system/name-service/switch> exit

root@sol-11:~# svcadm refresh name-service/switch

root@sol-11:~# svcadm restart name-service/switch

9、最关键一步验证

root@sol-11:~# ping www.baidu.com

www.baidu.com is alive

10、配置好了net0,下面是如何修改及删除IP配置:

a.)如果要删除net0 IP v4地址,添加新地址

root@sol-11:~# ipadm delete-addr net0/v4

root@sol-11:~# ipadm create-addr -T static -a 192.168.1.200/24 net0/v4

b.) 如果要删除网关

root@sol-11:~# route delete default 192.168.1.1

c.)如果要删除net0网卡

root@sol-11:~# ipadm delete-ip net0

附加:

查看网关、链路、ip地址

root@sol11:~# route -p show

persistent: route add default x.x.x.x

persistent: route add default x.x.x.x

persistent: route add -inet6 default x.x.x.x

persistent: route add -inet6 default x.x.x.x

查看链路状态:

root@sol11:~# dladm show-link

LINK CLASS MTU STATE OVER

net0 phys 1500 up --

net3 phys 1500 up --

zone1/net3 phys 1500 up --

net1 phys 1500 up --

net2 phys 1500 up --

zone1/net2 phys 1500 up --

zone1/net0 vnic 1500 up net0

root@lz-cache5:~# ipadm show-addr

ADDROBJ TYPE STATE ADDR

lo0/v4 static ok 127.0.0.1/8

lo0/v4a static ok x.x.x.x/32

net0/v4 static ok x.x.x.x/30

net1/v4 static ok x.x.x.x/30

lo0/v6 static ok ::1/128

lo0/v6a static ok x.x.x.x/128

net0/v6 addrconf ok fe80::525d:acff:fe05:d17c/10

net0/v6add static ok x.x.x.x/127

net1/v6 addrconf ok fe80::525d:acff:fe05:d17d/10

net1/v6add static ok x.x.x.x/127

查看端口速率:

# dladm show-phys

LINK MEDIA STATE SPEED DUPLEX DEVICE

net2 Ethernet up 1000 full bge0

net5 Ethernet unknown 0 unknown bge5

net1 Ethernet unknown 0 unknown bge3

net4 Ethernet unknown 0 unknown bge4

net3 Ethernet up 1000 full bge1

net0 Ethernet unknown 0 unknown bge2

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
2013年最新版的强悍Unix版本Solaris 11.1系统文件,功能十分强大,不愧是真正血统的Unix系统! Oracle Announces Availability of Oracle Solaris 11.1 and Oracle Solaris Cluster 4.1 Delivers Oracle Database and Java Enhancements, Expanded Mission Critical Cloud Management Capabilities and Advanced Platform Features Redwood Shores, Calif – October 26, 2012 News Facts Oracle today announced general availability of Oracle Solaris 11.1 and Oracle Solaris Cluster 4.1. Oracle Solaris 11 is the first cloud OS that allows customers to build large-scale enterprise-class Infrastructure as a Service (IaaS), Platform as a Service (PaaS) and Software as a Service (SaaS) clouds on a wide range of SPARC and x86 servers and Oracle engineered systems. Oracle Solaris Cluster 4.1 extends high availability and disaster recovery capabilities of Oracle Solaris and includes unique virtual cluster features supporting highly efficient application consolidation with best-in-class availability. Oracle Solaris 11 is already widely in production with thousands of customers with mission critical deployments across industries such as financial services, communications, healthcare, retail, public sector and media and entertainment. Read customer success stories about Oracle Solaris here. Oracle Solaris 11 is also gaining strong momentum among enterprise application vendors with hundreds of applications already qualified for Oracle Solaris Ready status through the Oracle PartnerNetwork (OPN). OPN members can develop, sell and implement their solutions on Oracle Solaris 11 and take advantage of specialized Oracle Solaris resources to expand their market reach. Customers and partners can quickly and safely upgrade to Oracle Solaris 11.1 using the built-in update tools and software repositories available with Oracle Solaris 11. Oracle will host a webcast on November 7, 2012 at 8 a.m. Pacific time on Oracle Solaris 11.1 and Oracle Solaris Cluster 4.1, featuring Markus Flierl, vice president, Oracle Solaris Engineering, Core Technology and Bill Nesheim, vice president, Oracle Solaris Engineering, Platform Software. Register here. This event will also include an interactive chat with core developers of Oracle Solaris and Oracle Solaris Cluster. New and Enhanced Features in Oracle Solaris 11.1 Oracle Solaris 11.1 increases the performance, availability and I/O throughput of the latest Oracle Database technology. A new, optimized shared memory interface between the Oracle Database and Oracle Solaris 11.1 provides 8x faster database startup and shutdown, as well as online resizing of the Oracle Database System Global Area (SGA). Oracle Solaris 11.1 introduces unique new capabilities for optimizing Oracle Database performance. Oracle Solaris 11.1 exposes Oracle Solaris DTrace I/O interfaces that allow an Oracle Database administrator to identify I/O outliers and subsequently isolate network or storage bottlenecks. A new Oracle Solaris DTrace plug-in for Oracle Java Mission Control to enable customers to profile Java applications on Oracle Solaris production systems. New cloud management features add to Oracle Solaris 11’s zero overhead built-in virtualization capabilities across system, network and storage resources, including expanded support for Software Defined Networks (SDN) with Edge Virtual Bridging enhancements, to maximize network resource utilization and manage bandwidth in cloud environments. New built-in memory predictor monitors application memory use and provides optimized memory page sizes and resource location to speed overall application performance. Support for an unprecedented 32 TB of RAM and thousands of CPUs unlocks the full potential of Oracle’s latest server systems. Oracle Solaris Cluster 4.1 Highlights New Oracle Solaris 10 Zone Clusters allow customers to consolidate mission critical Oracle Solaris 10 applications on Oracle Solaris 11 cloud environments. Expanded disaster recovery operations using Oracle’s Sun ZFS Storage Appliance services along with Oracle Solaris Cluster 4.1 to coordinate failover of applications and data to a remote disaster recovery site. Faster application recovery with improved storage failure detection and resource dependencies management. New labeled security capability in Oracle Solaris Zone Clusters provides military grade application separation in highly consolidated mission-critical deployments using Oracle Solaris 11 Trusted Extensions. Integrated Oracle Deployments and Support Oracle Enterprise Manager Ops Center provides comprehensive cloud management capabilities for Oracle Solaris 11, including self-service provisioning of Oracle Solaris 11 Zones. Ops Center’s integrated systems management delivers enterprise scale cloud performance. Oracle Enterprise Manager Ops Center is available to Oracle Solaris customers at no additional cost under the Ops Center Everywhere Program. Oracle Solaris Studio delivers the latest in compiler optimizations, multithread performance and powerful analysis tools for native development, and optimized application performance and reliability on Oracle Solaris 11.1 systems. Oracle Solaris 11 guarantees binary compatibility with previous Oracle Solaris versions through the Oracle Solaris Binary Application Guarantee Program, which provides customers a seamless upgrade path and the industry’s best investment protection. Oracle Solaris Legacy Containers allows older Oracle Solaris environments to be brought forward onto latest generation hardware to provide power, cooling and footprint consolidation savings. OPN members can find Oracle Solaris tools and resources in the Oracle Solaris Knowledge Zone, including Oracle Solaris Ready, Oracle Solaris 11 Specialization and Oracle Solaris Development Initiative. The Oracle Solaris Remote Lab now provides a secure cloud environment for OPN members to test and validate their applications with Oracle Solaris 11 in SPARC and x86 virtual environments. Supporting Quotes “Oracle recommends Oracle Solaris 11 for all UNIX®-based Oracle implementations. Oracle Solaris 11.1 delivers over 300 new performance and feature enhancements and is engineered together with Oracle Database, middleware, applications to increase performance, streamline management and automate support for Oracle deployments,” said John Fowler, executive vice president, Systems, Oracle. “The combination of the secure, highly available capabilities of Oracle Solaris Cluster 4.1 and the built-in virtualization of Oracle Solaris 11.1 helps customers bring their most mission-critical applications into a cost effective, agile cloud environment and delivers extreme availability for enterprise applications.” “Clients are looking for ways to reduce the complexity of systems management while enabling Platform as a Service (PaaS) & Software as a Service (SaaS) clouds,” says Lee Diamante, solutions architect, Systems Computing Solutions at Forsythe. “The value of Oracle Solaris 11 is that it maintains all the enterprise-class features expected with a mission-critical OS, while bringing in new, innovative technologies. Forsythe has a long and rich history of delivering customer solutions on Oracle Solaris systems. This is why we are excited about the Solaris 11.1 release.” “Oracle is making it much easier for partners like Informatica to gain access to their software with the new testing environments; shrinking the time to measurable results and value,” said Julie Lockner, vice president, ILM, Informatica. “With the release of Oracle Solaris 11.1 Informatica customers now have access to mission critical deployments across major industries, with an environment of high performance and high availability. With all the new feature enhancements, we look forward to making the Informatica Platform certified on the Oracle Solaris 11 product family.”

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值