华为交换机 查ip冲突_网络地址冲突(4个方案解决IP地址发生冲突问题?)

伴随着互联网的广泛运用,使互联网经营规模不断发展,相对的IP地址分派也在持续增加,IP地址矛盾状况日益增加,在一定水平上危害了互联网的一切正常运作。维护保养互联网平稳、高效率运作,处理IP地址矛盾难题,已变成网络安全管理中的关键每日任务之一,产生IP矛盾的原因是什么呢?如何解决IP矛盾的难题呢?

一、本人IP地址矛盾解决方法

1、假如您应用的电子计算机的操作系统:windows(windows7或window10都可以)。

这里边必须采用命信令:

ipconfig /release 释放出来IP地址。

随后还必须ipconfig /renew在再次获得一下。

大家看来下他们的如何解决:

能够 点一下左下方“刚开始”→“运作”,输入:ipconfig /release,点一下“明确”,把ip详细地址释放出。

这时候互联网会断掉,由于ip详细地址已释放出了。

再度点一下“刚开始”→“运作”,输入:ipconfig /renew,点一下“明确”,再次获取ip详细地址,就可以处理IP地址矛盾。

这时候互联网会再次联接,但ip详细地址早已与原先不一样了,分配来到能用的ip详细地址网络连接了。

二、局域网络IP地址矛盾解决方法

计划方案一、逐一清查

它是最初的方式 ,便是产生IP地址矛盾时,在局域网络内,靠着每台电子计算机查询,寻找两者之间矛盾的电子计算机后改动IP地址就可以了。但是那样较为费时间,也不宜在大中型局域网络中应用,只合适在不大的网络空间中选用。

计划方案二、MAC地址关联

1、查验当地电子计算机的MAC并关联:根据在当地计算机软件中运作Winipcfg/all,就可以测知网口的MAC地址。

那麼怎样关联ip详细地址与macMAC地址呢?

最先键入cmd进到指令配备符,随后键入指令ipconfig/all,查询本机ip及mac详细地址状况。

键入字符串数组指令“arp -s 10.168.1.1 34-F3-9A-2B-9E-13“,就可以关联。

随后键入指令arp -a查寻关联是不是取得成功。

很显著,默认网关详细地址10.168.1.143就被取得成功关联36-F3-9A-2B-9E-13, MAC地址到了,别的服务中心今后网上时假如抢用10.168.1.143详细地址时,便会出現不能上网的常见故障状况,如此一来全部局域网络的运作可靠性就能获得确保了。

计划方案三:端口号防护

针对所碰到的IP地址矛盾,还能够运用网络交换机的端口号把不一样的单位防护起来处理,这是由于运用网络交换机能够 对不一样的地区推行不一样的管理方法,历经切分的子网中间互相影响,能够 在 一定水平上处理IP地址矛盾的难题与数据信息的难题。

针对只有一个VLAN的互联网,端口号防护還是必须的。

大家看来个事例:

比如

一般状况下某一子公司都只有有一个vlan。在同一个VLAN下,不在阻拦全部单位跟总公司主机房网络服务器数据传输的状况下,完成子公司内各个部门A和各个部门B中间的数据信息屏蔽掉,可是以便确保订单信息精确下发至生产制造单位,因此单位A和单位B又可以与生产技术部数据通讯。

网络拓扑图

1、设定三个单位的IP地址:市场部A的IP地址:

92.168.10.2 255.255.255.0

市场部B的IP地址:

192.168.10.3 255.255.255.0

生产技术部的IP地址:

192.168.10.4 255.255.255.0

2、三层交换机配备(以华为交换机为例子

system 配备

[Huawei]sysname S5700

[S5700]vlan 10

[S5700-vlan10]quit

[S5700]int vlanif 10

[S5700-Vlanif10]ip address 192.168.10.1/24 //配备网关ip

[S5700-Vlanif10]quit

[S5700]int g0/0/1 //进到端口号g0/0/1

[S5700-GigabitEthernet0/0/1]port link-type access //配备端口号方式

[S5700-GigabitEthernet0/0/1]port default vlan 10 //添加vlan10

[S5700-GigabitEthernet0/0/1]port-isolate enable //添加端口号防护组1,且防护方式为二层防护三层相通。

[S5700-GigabitEthernet0/0/1]quit

[S5700]int g0/0/2 //进到端口号g0/0/2

[S5700-GigabitEthernet0/0/2]port link-type access

[S5700-GigabitEthernet0/0/2]port default vlan 10

[S5700-GigabitEthernet0/0/2]port-isolate enable //默认设置添加端口号防护组1,且防护方式为二层防护三层相通。

[S5700-GigabitEthernet0/0/2]quit

[S5700]int g0/0/3 //进到端口号 g0/0/3

[S5700-GigabitEthernet0/0/3]port link-type access

[S5700-GigabitEthernet0/0/3]port default vlan 10

[S5700-GigabitEthernet0/0/1]quit

3、检测結果

市场部A检测結果,市场部B相近

生产技术部检测結果

计划方案四:区划vlan

尽管可以用网络交换机来完成子网防护,进而在一定水平上防止IP地址矛盾的产生,但它仍不可以避免 因为同一个端口号下的子网内客户配备不正确而造成的IP地址矛盾。更强的解决方案便是,运用网络交换机来区划VLAN,再运用MAC地址关联的方式 来综合性解决。

小结:

假如必须防止局域网ip详细地址矛盾,最好ip详细地址关联电子计算机MAC地址,统一安排IP地址。计算机用户不可以自主变更IP地址,如变更IP地址则不能上网,新提升客户必须在管理人员那边获得已分派好的ip详细地址,那样绝大多数ip冲突的难题都能够防止。

来源于:莫然blog,热烈欢迎共享文中!

参与评论 您还未登录,请先 登录 后发表或查看评论
解决IP地址冲突的完美方法--DHCP SNOOPING 使用的方法是采用DHCP方式为用户分配IP,然后限定这些用户只能使用动态IP的方式,如果改成静态IP的方式则不能连接上网络;也就是使用了DHCP SNOOPING功能。 例子: version 12.1 no service pad service timestamps debug uptime service timestamps log uptime no service password-encryption service compress-config ! hostname C4-2_4506 ! enable password xxxxxxx! clock timezone GMT 8 ip subnet-zero no ip domain-lookup ! ip dhcp snooping vlan 180-181 // 对哪些VLAN 进行限制 ip dhcp snooping ip arp inspection vlan 180-181 ip arp inspection validate src-mac dst-mac ip errdisable recovery cause udld errdisable recovery cause bpduguard errdisable recovery cause security-violation errdisable recovery cause channel-misconfig errdisable recovery cause pagp-flap errdisable recovery cause dtp-flap errdisable recovery cause link-flap errdisable recovery cause l2ptguard errdisable recovery cause psecure-violation errdisable recovery cause gbic-invalid errdisable recovery cause dhcp-rate-limit errdisable recovery cause unicast-flood errdisable recovery cause vmps errdisable recovery cause arp-inspection errdisable recovery interval 30 spanning-tree extend system-id ! ! interface GigabitEthernet2/1 // 对该端口接入的用户进行限制,可以下联交换机 ip arp inspection limit rate 100 arp timeout 2 ip dhcp snooping limit rate 100 ! interface GigabitEthernet2/2 ip arp inspection limit rate 100 arp timeout 2 ip dhcp snooping limit rate 100 ! interface GigabitEthernet2/3 ip arp inspection limit rate 100 arp timeout 2 ip dhcp snooping limit rate 100 ! interface GigabitEthernet2/4 ip arp inspection limit rate 100 arp timeout 2 ip dhcp snooping limit rate 100 --More-- 编者注:对不需要明确地址的所有人的时候是一很好的解决办法。另外,可以查看www.cisco.com的 IP Source Guard Similar to DHCP snooping, this feature is enabled on a DHCP snooping untrusted Layer 2 port. Initially, all IP traffic on the port is blocked except for DHCP packets that are captured by the DHCP snooping process. When a client receives a valid IP address from the DHCP server, or when a static IP source binding is configured by the user, a per-port and VLAN Access Control List (PACL) is installed on the port. This process restricts the client IP traffic to those source IP addresses configured in the binding; any IP traffic with a source IP address other than that in the IP source binding will be filtered out. This filtering limits a host's ability to attack the network by claiming neighbor host's IP address.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:数字20 设计师:CSDN官方博客 返回首页

打赏作者

weixin_39801714

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值