linux安装eclipse出错,eclipse安装出错?新手求救!貌似JRE没起作用?

eclipse安装出错?新手求救!貌似JRE没起作用?

发布时间:2010-12-31 09:08:59来源:红联作者:sss520sss520xx

[i=s] 本帖最后由 sss520sss520xx 于 2010-12-31 09:38 编辑 [/i]

版本Redhat 9.0

下载的jre-6u23-i586.bin装在/usr/local/目录下,目录名为jre1.6.0_23,没有出现安装手册中的agree界面,直接Done了。

在/etc/profile中添加了JAVA_HOME=/usr/local/jre1.6.0_23

CLASSPATH=/usr/local/jre1.6.0_23/lib:/usr/local/jre1.6.0_23/lib

export JAVA_HOME CLASSPATH

安装eclipse出现的错误是:

Warning: -XX:MaxPermSize=256m not understood. Ignoring.

Warning: -Xms40m not understood. Ignoring.

Warning: -Xmx384m not understood. Ignoring.

Warning: -jar not understood. Ignoring.

Warning: -os not understood. Ignoring.

Warning: -ws not understood. Ignoring.

Warning: -arch not understood. Ignoring.

Warning: -showsplash not understood. Ignoring.

Warning: -launcher not understood. Ignoring.

Warning: -name not understood. Ignoring.

Warning: --launcher.library not understood. Ignoring.

Warning: -startup not understood. Ignoring.

Warning: -exitdata not understood. Ignoring.

Warning: -product not understood. Ignoring.

Warning: -vm not understood. Ignoring.

Warning: -vmargs not understood. Ignoring.

Warning: -XX:MaxPermSize=256m not understood. Ignoring.

Warning: -Xms40m not understood. Ignoring.

Warning: -Xmx384m not understood. Ignoring.

Warning: -jar not understood. Ignoring.

Exception in thread "main" java.lang.NoClassDefFoundError: .opt.EmbedSky.eclipse.plugins.org.eclipse.equinox.launcher_1.1.0.v20100507.jar

at 0x40268e17: java.lang.Throwable.Throwable(java.lang.String) (/usr/lib/./libgcj.so.3)

at 0x4025bc8e: java.lang.Error.Error(java.lang.String) (/usr/lib/./libgcj.so.3)

at 0x4025d6b6: java.lang.LinkageError.LinkageError(java.lang.String) (/usr/lib/./libgcj.so.3)

at 0x4025eb36: java.lang.NoClassDefFoundError.NoClassDefFoundError(java.lang.String) (/usr/lib/./libgcj.so.3)

at 0x402ad075: gnu.gcj.runtime.FirstThread.run() (/usr/lib/./libgcj.so.3)

at 0x4024fc4c: _Jv_ThreadRun(java.lang.Thread) (/usr/lib/./libgcj.so.3)

at 0x4021c8ac: _Jv_RunMain(java.lang.Class, byte const, int, byte const, boolean) (/usr/lib/./libgcj.so.3)

at 0x08048910: __gcj_personality_v0 (osgi.requiredJavaVersion=1.5)

at 0x42015574: __libc_start_main (/lib/tls/libc.so.6)

at 0x080486c1: _Jv_RegisterClasses (osgi.requiredJavaVersion=1.5)

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:1024 设计师:我叫白小胖 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值