poj 3070 Fibonacci

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts

Problems
Submit Problem
Online Status
Prob.ID:

Register
Update your info
Authors ranklist

Current Contest
Past Contests
Scheduled Contests
Award Contest
xxxxxxxxxxxx      Log Out
Mail:1(0)
Login Log      Archive

欢迎参加hihoCoder挑战赛35,线下活动同步报名中!

Language:Default

Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19271 Accepted: 13348

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

Stanford Local 2006

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator

 

水题:

矩阵快速幂题型详解见链接

牛客小白月赛6 洋灰三角(详解)

ac代码如下:

# include <iostream>
# include <cstring>
# define ll long long

using namespace std;

const int mod = 10000;

struct matrix
{
	ll m[5][5];
};

matrix ans,res;

void init()
{
	res.m[1][1]=1;
	res.m[1][2]=1;
	res.m[2][1]=1;
	res.m[2][2]=0;
	return ;
}

matrix calc(matrix a,matrix b)
{
	matrix temp;
	memset(temp.m,0,sizeof temp.m);
	for(int i=1;i<3;i++)
		for(int j=1;j<3;j++)
			for(int k=1;k<3;k++)
			{
				temp.m[i][j]+=a.m[i][k]*b.m[k][j];
				temp.m[i][j]%=mod;
			}
	return temp;
}

void quick_pow(int n)
{
	memset(ans.m,0,sizeof ans.m);
	for(int i=1;i<3;i++)
		ans.m[i][i]=1;
	
	while(n)
	{
		if(n&1)
			ans=calc(ans,res);
		res=calc(res,res);
		n>>=1;
	}	
	return ;	
}

int main()
{
	ll n;
	while(cin>>n,n!=-1)
	{
		if(n==0)
		{
			cout<<0<<endl;
			continue;
		}
		if(n==1)
		{
			cout<<1<<endl;
			continue;
		}
		ll sum=0;
		init();
		quick_pow(n-1);
		sum=ans.m[1][1];
		cout<<sum<<endl;
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值