POJ2236(并查集,逐一遍历)

Wireless Network
Time Limit: 10000MS

Memory Limit: 65536K
Total Submissions: 38055

Accepted: 15753
Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
一开始感觉没有思路,并查集可以找出逻辑关系,可是题目中的位置关系不知怎么处理,首先想到的就是BFS可是现在细细想来,自己脑子怕是坏掉了,BFS的目的是寻找可用数据,其实数据已经有了,在已有数据中寻找就OK了。
将可以连通的用并查集连接在一起

//并查集题目表示关系
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#define MAXN 1005
using namespace std;
int father[MAXN];//并查集,表示是否连通
int flag[MAXN];//标记是否可用
int distion[MAXN][2];//记录位置
int n,d;

int mfind(int x){
    int r = x;
    while(r!=father[r]){
        r = father[r];
    }
    int i = x,j;
    while(i!=r){
        j = father[i];
        father[i] = r;
        i =j;
    }
    return r;//返回根节点
}
void connect(int x,int y){
    int nx = mfind(x);
    int ny = mfind(y);
    if(nx!=ny){
        father[nx] = ny;
    }
}
int main()
{
    scanf("%d%d",&n,&d);
    memset(flag,0,sizeof(flag));
    for(int i=1;i<=n;i++){
        scanf("%d%d",&distion[i][0],&distion[i][1]);
        father[i] = i;//初始化并查集
    }
    char operation;
    getchar();
    while(~scanf("%c",&operation)){
        if(operation=='O'){
            int tmp;
            scanf("%d",&tmp);
            if(flag[tmp])
                continue;
            flag[tmp] = true;
            for(int i=1;i<=n;i++){
                if(flag[i]&&(distion[i][0]-distion[tmp][0])*(distion[i][0]-distion[tmp][0])+(distion[i][1]-distion[tmp][1])*(distion[i][1]-distion[tmp][1])<=d*d){
                    connect(i,tmp);
                }
            }
        }
        else{
            int tmp1,tmp2;
            scanf("%d%d",&tmp1,&tmp2);
            if(mfind(tmp1)==mfind(tmp2)){
                printf("SUCCESS\n");
            }
            else{
                printf("FAIL\n");
            }
        }
        getchar();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值