自负哈希,字典树——Message Flood(未解决)

Message Flood

Time Limit: 1500 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Sample Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

Sample Output

3

Step 1:题意,个人理解,多组输入,第一行里输入n,m,当n=0的时候结束。

接下来n行,输入n个名字;接下来m行输入m个名字;

然后在n中把m中出现的名字去掉,最后输出剩下几个。(m中可能有n中没出现过的,无需处理)

Tips:应该可以用哈希做,因为这个题分类属于 字符哈希,还有用字典树的(原谅我的无知,我不会)~

Step 2:实现。(可惜WA,而且应该还会超时.....)

#include<stdio.h>
#include<string.h>
struct node
{
    char name[25];
} L[20008],Q[20008];
int main()
{
    int  n, i, j,m,sum;
    while(~scanf("%d",&n)&&n!=0)
    {
        scanf("%d",&m);
        int flag[20008] = {0};
        for(i = 1; i <= n; i++)
        {
            scanf("%s",L[i].name);
        }
        for(j = 1; j <= m; j++)
        {
            scanf("%s",Q[j].name);
        }
        j = 1;i = 1;sum = n;
        while(i <= n&&j<=m)
        {
            if(strcmp(Q[j].name,L[i].name) == 0 && !flag[i])
            {
                flag[i] = 1;
                sum--;
                j++;i=0;
            }
            else
            {
                i++;
            }
        }
        printf("%d\n",sum);
       
    }
    return 0;
}

附上网友字典树做的:

#include <stdio.h>
#include <string.h>
#include <algorithm>

struct node
{
    int v;
    node *next[26];
};
node *newnode()
{
    node *p=new node;
    p->v=0;
    for(int i=0;i<26;i++)
    {
        p->next[i]=NULL;
    }
    return p;
}
void insertnode(node *root,char *str)
{
    node *p=root;
    int l=strlen(str);
    for(int i=0;i<l;i++)
    {
        int t;
        if(str[i]>='a')
            t=str[i]-'a';
        else t=str[i]-'A';
        if(p->next[t]==NULL)
        {
            p->next[t]=newnode();
        }
        p=p->next[t];
    }
    p->v=1;
}
int find(node *root,char *str)
{
    node *p=root;
    int l=strlen(str);
    for(int i=0;i<l;i++)
    {
        int t;
        if(str[i]>='a')
            t=str[i]-'a';
        else t=str[i]-'A';
        if(p->next[t]==NULL)
            return 0;
        else p=p->next[t];
    }
    if(p->v==1)
        return 1;
    return 0;
}
int main()
{
    int n,m;
    int i;
    char name[30000][15],send[100000];
    while(~scanf("%d",&n)&&n)
    {
        int c=0;
        node *root=newnode();
        scanf("%d%*c",&m);
        for(i=0;i<n;i++)
        {
            scanf("%s",name[i]);
        }
        for(i=0;i<m;i++)
        {
            scanf("%s",send);
            insertnode(root,send);
        }
        for(i=0;i<n;i++)
        {
            if(!find(root,name[i]))
                c++;
        }
        printf("%d\n",c);
    }
}

还有位同学使用map函数做的,不贴码,贴地址

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值