Ubuntu 安装sbt遇到的坑(亲测有效)

 

之前在安装sbt时,遇到不少的坑。在这里记录一下

具体安装步骤可以看林子雨老师的教程:http://dblab.xmu.edu.cn/blog/spark-quick-start-guide/(教程最下面部分)。但使用这个教程得有个前提,就是你的jdk版本必须在1.8以上(包括1.8),如下我的jdk版本:

详细的jdk的安装可参见这篇博客:https://blog.csdn.net/sinat_37205087/article/details/82799814

1.7的jdk版本在执行下面这条命令后会报错(依赖包下载不了)

./sbt sbt-version

出现错误时,有些教程会让你编辑下面这个文件:

vim ./sbt/sbt.boot.properties

[repositories]
  local
  maven-central
  typesafe-ivy-releases: https://repo.typesafe.com/typesafe/ivy-releases/, [organization]/[module]/[revision]/[type]s/[artifact](-[classifier]).[ext], bootOnly
  sbt-ivy-snapshots: https://repo.scala-sbt.org/scalasbt/ivy-snapshots/, [organization]/[module]/[revision]/[type]s/[artifact](-[classifier]).[ext], bootOnly

教程会让你将上面的https全部改为http,并添加下面这行代码,其实下面这行代码的url已经完全无法连接,不信的话可以用浏览器试一下,这是一个大坑。

oschina: http://maven.oschina.net/content/groups/public/

 

 

总结一下:如果你的jdk是1.7及以下安照上面这种方法是没有用的,最好的方法是升级你的jdk(1.8以上)。

展开阅读全文
©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值