Knight Moves(广搜)

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

InputThe input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
OutputFor each test case, print one line saying "To get from xx to yy takes n knight moves.". 
Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

按马的行走方式,8个方向,很简单,下面一题也一样

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int mp[26][26],vis[26][26];
int ty[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int tx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
char a[3],b[3];
int sx,sy,ex,ey,n,m,flag,minstep;

struct node
{
 int x,y,step;
};

void bfs()
{
 queue<node> que;
 node q,p;
 q.x=sx,q.y=sy,q.step=0;
 que.push(q);
 while(!que.empty())
 {
  q=que.front();
  if(q.x==ex&&q.y==ey)
   {
    printf("To get from %s to %s takes %d knight moves.\n",a,b,q.step);
    return ;
   }
  que.pop();
  for(int i=0;i<8;i++)
    {
      p=q;
      p.x+=tx[i];
      p.y+=ty[i];
     if(p.x>=1&&p.x<=8&&p.y>=1&&p.y<=8)
        if(!vis[p.x][p.y])
        {
           p.step=p.step+1;
           vis[p.x][p.y]=1;
           que.push(p);
        }
    }
 }
}

int main()
{
    while(scanf("%s%s",&a,&b)!=EOF)
    {
     memset(vis,0,sizeof(vis));
     minstep=999999;
     sx=a[0]-'a'+1;
     sy=a[1]-'0';
     ex=b[0]-'a'+1;
     ey=b[1]-'0';
     vis[sx][sy]=1;
     bfs();
    }
    return 0;
}

 

 

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1.

 

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int mp[301][301],vis[301][301];
int ty[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int tx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int sx,sy,ex,ey,n,m,flag,minstep;

struct node
{
 int x,y,step;
};

void bfs()
{
 queue<node> que;
 node q,p;
 q.x=sx,q.y=sy,q.step=0;
 que.push(q);
 while(!que.empty())
 {
  q=que.front();
  if(q.x==ex&&q.y==ey)
   {
    printf("%d\n",q.step);
    return ;
   }
  que.pop();
  for(int i=0;i<8;i++)
    {
      p=q;
      p.x+=tx[i];
      p.y+=ty[i];
      if(p.x>=0&&p.x<n&&p.y>=0&&p.y<n)
         if(!vis[p.x][p.y])
         {
            p.step=p.step+1;
            vis[p.x][p.y]=1;
            que.push(p);
         }
    }
 }
}

int main()
{
    int x;
    scanf("%d",&x);
    while(x--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d%d%d%d%d",&n,&sx,&sy,&ex,&ey);
        bfs();
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值