Bi-shoe and Phi-shoe LightOJ - 1370 (欧拉函数)

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题目大意:对于给出的所有数,求欧拉函数值大于等于所给的数的最小数的和。

解题思路:用埃氏筛或者欧拉筛预处理,对所给的数从小到大遍历一遍即可。

埃氏筛:

void table (){
    for (int i = 1; i <= Maxn; i++) kep[i] = i ;
    for (int i = 2; i <= Maxn; i++){
        if (kep[i] == i) {
            for (int j = i; j <= Maxn; j += i){
                kep[j] = kep[j] / i * (i - 1) ;
            }
        }
    }
}

欧拉筛:

void table (){
    kep[1] = 1 ;
    int num = 0 ;
    for (int i = 2; i <= Maxn; i++){
        if (vis[i] == 0) {
            prime[++num] = i ;
            kep[i] = i - 1 ;
        }
        for (int j = 1; j <= num && prime[j] * i <= Maxn; j++){
            vis[i * prime[j]] = 1 ;
            if (i % prime[j] == 0 ){
                kep[i * prime[j]] = kep[i] * prime[j] ;
                break ;
            }
            else kep[i * prime[j]] = kep[i] * kep[prime[j]] ;
        }
    }
}
/*
@Author: Top_Spirit
@Language: C++
*/
//#include <bits/stdc++.h>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std ;
typedef long long ll ;
typedef pair < ll, ll > P ;
const int Maxn = 1e6 + 10 ;
const int INF = 1 << 30 ;

int a[Maxn] ;
int n ;
ll kep[Maxn] ;

//void table (){
//    for (int i = 1; i <= Maxn; i++) kep[i] = i ;
//    for (int i = 2; i <= Maxn; i++){
//        if (kep[i] == i) {
//            for (int j = i; j <= Maxn; j += i){
//                kep[j] = kep[j] / i * (i - 1) ;
//            }
//        }
//    }
//}

int vis[Maxn], prime[Maxn] ;

void table (){
    kep[1] = 1 ;
    int num = 0 ;
    for (int i = 2; i <= Maxn; i++){
        if (vis[i] == 0) {
            prime[++num] = i ;
            kep[i] = i - 1 ;
        }
        for (int j = 1; j <= num && prime[j] * i <= Maxn; j++){
            vis[i * prime[j]] = 1 ;
            if (i % prime[j] == 0 ){
                kep[i * prime[j]] = kep[i] * prime[j] ;
                break ;
            }
            else kep[i * prime[j]] = kep[i] * kep[prime[j]] ;
        }
    }
}


int main (){
    int T, Cas = 0 ;
    table() ;
//    for (int i = 1; i <= 20; i++){
//        cout << kep[i] << " " ;
//    }
    cin >> T ;
    while (T--){
        cin >> n ;
        ll ans = 0 ;
        for (int i = 1; i <= n; i++){
            cin >> a[i] ;
//            ans += kep[a[i]] ;
        }
        sort(a + 1, a + n + 1) ;
        int j = 1 ;
        for (int i = 2; i <= Maxn; i++){
            while (kep[i] >= a[j] && j <= n) {
                j++ ;
                ans += i ;
            }
            if (j == n + 1) break ;
        }
        cout << "Case " << ++Cas << ": " ;
        cout << ans << " " << "Xukha" << endl ;
    }
    return 0 ;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值