PAT 1088 Rational Arithmetic (20 分)

1088 Rational Arithmetic (20 分)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.


Input Specification:
Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.


Output Specification:
For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf




解析

可以去看看算法笔记中怎么处理分数的。PAT & MATH
这题代码量有点大,但是不算很难。
要用long long.因为题目都疯狂暗示了:It is guaranteed that all the output integers are in the range of long int.





Code:

#include<cstdio>
#include<cstdlib>
using namespace std;
using INT64 = long long;
typedef struct {
	INT64 up, down;
}Fraction;
INT64 gcd(INT64 a, INT64 b) {
	if (b == 0)
		return a;
	else
		return gcd(b, a%b);
}
Fraction reduction(Fraction a) {
	if (a.down < 0) {
		a.up = -a.up;
		a.down = -a.down;
	}
	if (a.up == 0)
		a.down = 1;
	else {
		int d = gcd(abs(a.up), abs(a.down));
		a.up /= d;
		a.down /= d;
	}
	return a;
}
Fraction add(Fraction a, Fraction b) {
	Fraction c;
	c.up = a.up*b.down + b.up*a.down;
	c.down = a.down*b.down;
	return reduction(c);
}
Fraction sub(Fraction a, Fraction b) {
	Fraction c;
	c.up = a.up*b.down - a.down*b.up;
	c.down = a.down*b.down;
	return reduction(c);
}
Fraction muiti(Fraction a, Fraction b) {
	Fraction c;
	c.up = a.up*b.up;
	c.down = a.down*b.down;
	return reduction(c);
}
Fraction divide(Fraction a, Fraction b) {
	Fraction c;
	c.up = a.up*b.down;
	c.down = b.up*a.down;
	return reduction(c);
}
using F=Fraction(*)(Fraction a, Fraction b);
void show(Fraction a) {
	if (a.up < 0)
		printf("(");
	if (a.down == 1)
		printf("%lld", a.up);
	else if (abs(a.up) > a.down)
		printf("%lld %lld/%lld", a.up / a.down, abs(a.up) % a.down, a.down);
	else
		printf("%lld/%lld", a.up, a.down);
	if (a.up < 0)
		printf(")");
}
int main()
{
	Fraction f1, f2;
	scanf("%lld/%lld %lld/%lld", &(f1.up), &(f1.down), &(f2.up), &(f2.down));
	f1 = reduction(f1);
	f2 = reduction(f2);
	F functiontable[4]{ add,sub,muiti,divide };
	char SignTable[4]{ '+','-','*','/' };
	for (int i = 0; i < 4; i++) {
		show(f1);
		printf(" %c ", SignTable[i]);
		show(f2);
		printf(" = ");
		if (i == 3 && f2.up == 0)
			printf("Inf");
		else {
			Fraction result = functiontable[i](f1, f2);
			show(result);
		}
		printf("\n");
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
8.17 (Rational Numbers) Create a class called Rational for performing arithmetic with fractions. Write a program to test your class. Use integer variables to represent the private instance variables of the class the numerator and the denominator. Provide a constructor that enables an object of this class to be initialized when it is declared. The constructor should store the fraction in reduced form. The fraction 2/4 is equivalent to 1/2 and would be stored in the object as 1 in the numerator and 2 in the denominator. Provide a no-argument constructor with default values in case no initializers are provided. Provide public methods that perform each of the following operations: a. Add two Rational numbers: The result of the addition should be stored in reduced form. b. Subtract two Rational numbers: The result of the subtraction should be stored in reduced form. c. Multiply two Rational numbers: The result of the multiplication should be stored in reduced form. d. Divide two Rational numbers: The result of the division should be stored in reduced form. e. Print Rational numbers in the form a/b, where a is the numerator and b is the denominator. f. Print Rational numbers in floating-point format. (Consider providing formatting capabilities that enable the user of the class to specify the number of digits of precision to the right of the decimal point.) – 提示: – 有理数是有子、母以形式a/b表示的数,其中a是子,b是母。例如,1/3,3/4,10/4。 – 有理数的母不能为0,子却可以为0。每个整数a等价于有理数a/1。有理数用于数的精确计算中。例如1/3=0.0000…,它不能使用数据类型double或float的浮点格式精确表示出来,为了得到准确结果,必须使用有理数。 – Java提供了整数和浮点数的数据类型,但是没有提供有理数的类型。 – 由于有理数与整数、浮点数有许多共同特征,并且Number类是数字包装的根类,因此,把有理数类Rational定义为Number类的一个子类是比较合适的。由于有理数是可比较的,那么Rational类也应该实现Comparable接口。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值