android studio 在添加RecyclerView依赖库之后出现cannot resolve symbol 'R',试过找到的方法,最后发现是依赖有问

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/weixin_41678415/article/details/79753511

自己百度了下找到的方法都试了下,问题没有解决,最后经过几次尝试算是解决了问题:

我试过的方法有

1.重启Android studio 。

2.rebuild/clean project

3.将“idea.max.intellisense.filesize”的默认2500更改为5000

4.同步gradle (Sync project with Gradle Files)

问题似乎是在添加了RecycleView依赖库的文件后出现了,但不确定之间有必然关系。

添加RecycleView依赖库的文件

我的android studio版本是 3.0.1


底下的messages有一些提示信息,然看不懂……


最终解决方案:

一:file——project strutrue——app——dependencies更改导入的com.android.support.recyclerview-v7:28.0.0-alpha1。依据dependencies中的      com.android.support.appcompat-v7:26.1.0 故将其改为:

com.android.support.recyclerview-v7:26.1.0 

二 :reBuild 项目,启动模拟器,可以运行。

三 :总结:至于为什么这么做,是因为也试过书上的低版本recyclerview,但是提示版本不匹配的问题,故采用和appcompat版本一样的信息。。而删除alpha1,则是看到别的博文中有提到这样的方法。

问题是在我学习《android 编程权威指南》第三版   这本书的课程章节时出现。具体的内部原理我不是很理解,不过按照上面的方法,问题是解决了

记给自己看的:这个bug前后经过下面几个阶段:

一  请学长帮忙找问题,解决编译无法通过的问题(通过更改布局文件xml的依赖关系。添加android的内部类AlertControler暂时解决问题,且删掉库依赖的关系)

        1) android.support.v7.widget.RecyclerView改为 android.support.v7.app.AlertController.RecycleListView

  2) 在android——app——Gradle Scripts——build.gradle(Module:app)中删掉添加的

com.android.support.recyclerview-v7:28.0.0-alpha1

    

二 又到后来出问题,再次添加依赖库,到暂时解决无法通过编译的问题。

三 最后发现无法在模拟器中运行(无法打开该APP),怀疑还是原先的recyclerview的依赖关系有问题。故返回最终解决方案。


展开阅读全文

没有更多推荐了,返回首页