Rock, Paper, Scissors

Description:

Rock, Paper, Scissors is a classic hand game for two people. Each participant holds out either a fist (rock), open hand (paper), or two-finger V (scissors). If both players show the same gesture, they try again. They continue until there are two different gestures. The winner is then determined according to the table below:
 
Rock beats Scissors   
Paper beats Rock   
Scissors beats Paper 
Your task is to take a list of symbols representing the gestures of two players and determine how many games each player wins.
In the following example:

Turn     : 1 2 3 4 5
Player 1 : R R S R S
Player 2 : S R S P S
Player 1 wins at Turn 1 (Rock beats Scissors), Player 2 wins at Turn 4 (Paper beats Rock), and all the other turns are ties.

Input:

The input contains between 1 and 20 pairs of lines, the first for Player 1 and the second for Player 2. Both player lines contain the same number of symbols from the set {'R', 'P', 'S'}.  The number of symbols per line is between 1 and 75, inclusive.  A pair of lines each containing the single character 'E' signifies the end of the input.

Output:

For each pair of input lines, output a pair of output lines as shown in the sample output, indicating the number of games won by each player.

Sample Input:

RRSRS
SRSPS
PPP
SSS
SPPSRR
PSPSRS
E
E

Sample Output:

P1: 1
P2: 1
P1: 0
P2: 3
P1: 2
P2: 1

Note:

本题由旧版NOJ导入,来源:ACM Mid-Central Regional 2009

 

#include <iostream>
#include <string>
#include <unordered_map>
#include <unordered_set>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
#include <climits>
#include <stdio.h>
#include <iomanip>
#include <math.h>   
#include <list>
#include <queue>
#include <tuple> 
#include <stack>
#include <string.h>
using namespace std;

int main(void)
{
	string a, b;
	while(1)
	{
		cin >> a >> b;
		if(a[0] == 'E' && b[0] == 'E')
			return 0;
		int win1 = 0;
		int win2 = 0;
		for(int i = 0; i < a.length(); i++)
		{
			if(a[i] == b[i])
				continue;
			else if(a[i] == 'R' && b[i] == 'S')
				win1++;
			else if(a[i] == 'R' && b[i] == 'P')
				win2++;
			else if(a[i] == 'S' && b[i] == 'P')
				win1++;
			else if(a[i] == 'S' && b[i] == 'R')
				win2++;
			else if(a[i] == 'P' && b[i] == 'R')
				win1++;
			else if(a[i] == 'P' && b[i] == 'S')
				win2++;
		}
		cout << "P1: " << win1 << endl;
		cout << "P2: " << win2 << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值