Error开始:安装老版本Android Studio出现的错误

     新版本(3.1)的Android  Studio出现后,因为找不到Device Monitor这个很好用的工具,就装回了2.3.3版本,结果总是出现

的错误,搞了一个通宵没搞好,最后在贴吧里看到一个解决方案,完美解决,好想亲他一口。

方案为:

添加此方法到项目构建.gradle(app)文件中的buildTypes添加:
repositories { maven { url "https://maven.google.com" }}
这是因为需要添加google()来解决它,因为你使用到Android studio 3.0中的bug,这里需要全新的梯度插件来解决这个问题,
在Android studio 3.0之前:检查你的系统中是否安装了支持库(检查系统中的SDK目录),或者检查是否安装在SDK管理器中。
或者正如这个答案所陈述的
从版本26的支持库开始,确保存储库部分包括一个带有“https://maven.google.com”端点的maven部分

buildTypes {

repositories {
maven {
url "https://maven.google.com"
}
}
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}

}

第二种解决方法:

点击打开链接

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页