ural 1017 Staircases (动态规划)

One curious child has a set of N little bricks. From these bricks he builds different staircases. Staircase consists of steps of different sizes in a strictly descending order. It is not allowed for staircase to have steps equal sizes. Every staircase consists of at least two steps and each step contains at least one brick. Picture gives examples of staircase for N=11 and N=5:
Your task is to write a program that reads from input numbers N and writes to output numbers Q - amount of different staircases that can be built from exactly N bricks.
Input
Numbers N, one on each line. You can assume N is between 3 and 500, both inclusive. A number 0 indicates the end of input.
Output
Numbers Q, one on each line.
Sample Input
3
5
0
Sample Output
1
2
一个好奇的小孩子有N个小砖块(5<=N<=500).用这些砖块,他搭建了一些不同的楼梯。楼梯由严格递减的梯子序列组成,楼梯不允许有相同的两梯。每个楼梯至少有2格,每格至少有一个砖块。读入N,输出唯一的数Q–能用N块砖搭建的不同梯子的总数。

dp[i][j]表示使用i个砖块,最后一个列的方块数量为j的不同方案数
最后考虑每个楼梯都必须包含至少两层(也就是不可以只有一列),这时只需要最终答案减1.

搞了好长时间都没弄懂,只是大体上明白一点意思,附上转载链接:https://blog.csdn.net/u010005180/article/details/56495425

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

long long dp[505][505];
int main(){
    int n;
    while (scanf("%d", &n)!=EOF && n){
    	memset(dp, 0, sizeof(dp));
    	dp[0][0]=1;
    	for (int i=1; i<=n; i++){
    		for (int j=1; j<=i; j++){
    			for (int k=0; k<=min(i-j, j-1); k++){
    				dp[i][j]=dp[i][j]+dp[i-j][k];
				}
			}
		}
		long long ans=0;
		for (int j=0; j<=n; j++)	
			ans+=dp[n][j];
		printf("%lld\n", ans-1);
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值