PAT Advanced 1015 Reversible Primes

1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No
题目大意

给定 一个数 转化为 k进制后,取反向转化为10进制后, 问是否是 质数, 如果是输出 Yes, 否则为 No

解题代码
#include <cstdio>
using namespace std;
int a[100010];
bool is_prime(int x){
    if (x < 2 ) return false;
    for (int i = 2; i <= x / i; i++)
        if (x % i == 0) return false;
    return true;
}
int main(){
    int n, d;
    while(scanf("%d %d", &n, &d) && n > 0){
        if (!is_prime(n)) {puts("No"); continue;}
        int sum = 0, len = 0, k = 1;
        while(n > 0){
            a[len ++] = n % d;
            n /= d;
        }
        for (int i = len - 1; i >= 0; i --){
            sum += a[i] * k;
            k *= d;
        }
        printf("%s\n", is_prime(sum) ? "Yes" : "No");
    }
    return 0;
}

改进

转化对应的进制时,使用反向相乘 + 余数的形式

#include <cstdio>
using namespace std;
int a[100010];
bool is_prime(int x){
    if (x < 2 ) return false;
    for (int i = 2; i <= x / i; i++)
        if (x % i == 0) return false;
    return true;
}
int main(){
    int n, d;
    while(scanf("%d %d", &n, &d) && n > 0){
        if (!is_prime(n)) {puts("No"); continue;}
        int sum = 0, len = 0, k = 1;
        while(n > 0){
            a[len ++] = n % d;
            n /= d;
        }
        for (int i = 0; i < len; i++) n = n * d + a[i];
        printf("%s\n", is_prime(n) ? "Yes" : "No");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值