PAT Advanced 1102 Invert a Binary Tree

1102 Invert a Binary Tree

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.   

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6    

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

解题思路

给定一颗二叉树,将它左右孩子结点转换后,重新构建一颗二叉树, 输出层序遍历和前序遍历的结果,如下图解析输入案例:

由上图解, 解题步骤如下:

  1. 通过给定的输入序列构建二叉树(通过dfs)
  2. 构建完成层序遍历使用bfs
  3. 前序遍历每个结点 dfs

注意输出格数:中间的空格以及,并且结尾没有空格。

解题代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;
int cnt, n, h[20], tree[20][2], invt[20][2];
void dfs(int v){
    if (v == -1) return;
    dfs(tree[v][0]), dfs(tree[v][1]);
    swap(tree[v][0], tree[v][1]);
}
void print(int v){
    printf("%d", v);
    cnt ++;
    if (cnt < n) printf(" ");
}
void preorder(int v){
    if (v == -1) return;
    preorder(tree[v][0]);
    print(v);
    preorder(tree[v][1]);
}
void bfs(int root){
    queue<int> q;
    q.push(root);
    while (!q.empty()){
        int top = q.front();
        q.pop();
        print(top);
        if (tree[top][0] != -1) q.push(tree[top][0]);
        if (tree[top][1] != -1) q.push(tree[top][1]);
    }
}
int main(){
    scanf("%d", &n);
    for (int i = 0; i < n; i++){
        string sl, sr;
        cin >> sl >> sr;
        tree[i][0] = tree[i][1] = -1;
        if (sl != "-") tree[i][0] = stoi(sl), h[stoi(sl)] = 1;
        if (sr != "-") tree[i][1] = stoi(sr), h[stoi(sr)] = 1;
    }
    int root;
    for(int i = 0; i < n; i ++) if (!h[i]) root = i;
    dfs(root);
    bfs(root);
    puts(""), cnt = 0;
    preorder(root);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值