如何将javaWeb3.1+版本项目 降版本 更换jdk及tomcat

首先:配置eclipse的运行server:我们配置成tomcat7版本+jdk1.7版本;然后把之前的web项目添加到服务器中
,但是提示添加失败:因为我们之前的项目NetWatcher是基于基于tomcat8+jdk1.8开发的DynamicWebProject选择
的时候 我们选了3.1版本;所以无法运行在jdk1.7+tomcat7上
这时 我们需要修改项目的配置:在eclipse界面中 将java的版本降为1.7;DynamicWebM的版本降为3.0;但是界面中只能修改java的版本,无法修改Dynamic的版本,我们需要到项目源码的文件中,修改.settings文件夹下的配置文件
在源码路径下,修改.settings文件夹下的如下 配置文件:修改如下文件
打开修改:修改为3.0;web项目版本只能在此处修改,eclipse配置界面 改不了
另外:web.xml文件无需修改版本
展开阅读全文

没有更多推荐了,返回首页