cisco思科网络设备的MIB信息访问

一、实验目的

本实验的主要目的是学习SNMP服务在交换机和路由器的配置,以及用MIB浏览器访问交换机和路由器的的MIB对象的值,重点了解其相应的网络管理对象。并通过SNMP来实现监控和配置网络设备。

二、实验内容

1、交换机和路由器SNMP配置;

2、通过SNMP来实现监控和配置网络设备。

三、实验工具

Packet tracer模拟器。

四、实验环境

                                                       

五、实验步骤

1、启动Packet tracer 模拟器,按图所示在连接网络

2、单击图中路由器图标,在弹出窗口中选择CLI标签,输入以下命令,配置路由器的以太口的IP地址和SNMP的共同体

Router>enable

Router#config t

Router(config)#hostname R1

R1(config)#interface fastethernet0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#snmp-server community private ro

R1(config)#snmp-server community public rw

3、单击图中交换机图标,在弹出窗口中选择CLI标签,输入以下命令配置交换机的管理IP 和交换机的SNMP共同体名

Switch>enable

Switch#config t

Switch(config)#interface vlan1

Switch1(config-if)# no shut

Switch(config-if)#ip address 192.168.1.2.255.255.255.0

Switch(config-if)#exit

Switch(config)#snmp-server community  private  ro

Switch(config)# snmp-server community  public  rw

 

                               

4、点击PC图标,在弹出对话框中,选择IP configuration 配置,设置PCIP地址和网关。5、通过MIBBrowser查看和设置路由器的管理对象的值。方法如下 :

1)点击图的的电脑图标,在弹出对话框中选择MIBBrowser图标,然后点击“advanced”按钮,在address 文本框中填入要管理的路由器的IP地址192.168.1.1,在Read Community中只读共同体名private,在Write Community中填入读写共同体public

2)最大化图形窗口,在MIB Tree树精确查找我们需要的信息节点(也可以在OID文本中输入要访问的对象ID) ,在Operations中选择get操作方式,点击go按钮就可以获取相应结点的信息。在实验过程中大家重点了解SystemifTableipRouteTable等结点下的所有对象的值。

6、通过MIBBrowser查看和设置交换机的管理对象的值。点击“advanced”按键,输入交换机的管理IP和共同体名(方法同上)。按照上面方法查看SystemifTableipRouteTable等结点下的所有对象的值。

 

System

                    

ifTable


                    

ipRouteTable


                          

5、实验体会。

通过本次实验,学习SNMP服务在交换机和路由器的配置,以及用MIB浏览器访问交换机和路由器的的MIB对象的值,了解其相应的网络管理对象。并通过SNMP来实现监控和配置网络设备。

 


相关推荐
v2, 0 , 2018-05-10 v2\ACCOUNTING-CONTROL-MIB.cds, 18985 , 2018-05-10 v2\ACCOUNTING-CONTROL-MIB.cmi, 6194 , 2018-05-10 v2\ACCOUNTING-CONTROL-MIB.my, 30336 , 2002-11-22 v2\ACTONA-ACTASTOR-MIB.cds, 13848 , 2018-05-10 v2\ACTONA-ACTASTOR-MIB.cmi, 10955 , 2018-05-10 v2\ACTONA-ACTASTOR-MIB.my, 39991 , 2010-08-13 v2\ADMIN-AUTH-STATS-MIB.cds, 4461 , 2018-05-10 v2\ADMIN-AUTH-STATS-MIB.cmi, 3424 , 2018-05-10 v2\ADMIN-AUTH-STATS-MIB.my, 10304 , 2011-01-28 v2\ADSL-DMT-LINE-MIB.cds, 6749 , 2018-05-10 v2\ADSL-DMT-LINE-MIB.cmi, 5994 , 2018-05-10 v2\ADSL-DMT-LINE-MIB.my, 24097 , 2000-04-14 v2\ADSL-LINE-MIB.cds, 68176 , 2018-05-10 v2\ADSL-LINE-MIB.cmi, 41579 , 2018-05-10 v2\ADSL-LINE-MIB.my, 159225 , 2001-12-04 v2\ADSL-TC-MIB.cds, 3218 , 2018-05-10 v2\ADSL-TC-MIB.cmi, 655 , 2018-05-10 v2\ADSL-TC-MIB.my, 4292 , 2001-12-04 v2\ADSL2-LINE-MIB.cds, 112735 , 2018-05-10 v2\ADSL2-LINE-MIB.cmi, 50458 , 2018-05-10 v2\ADSL2-LINE-MIB.my, 219014 , 2010-10-29 v2\ADSL2-LINE-TC-MIB.cds, 18387 , 2018-05-10 v2\ADSL2-LINE-TC-MIB.cmi, 6727 , 2018-05-10 v2\ADSL2-LINE-TC-MIB.my, 31400 , 2010-05-04 v2\AIRESPACE-REF-MIB.cds, 1166 , 2018-05-10 v2\AIRESPACE-REF-MIB.cmi, 356 , 2018-05-10 v2\AIRESPACE-REF-MIB.my, 1567 , 2006-06-14 v2\AIRESPACE-SWITCHING-MIB.cds, 55152 , 2018-05-10 v2\AIRESPACE-SWITCHING-MIB.cmi, 40917 , 2018-05-10 v2\AIRESPACE-SWITCHING-MIB.my, 150336 , 2006-06-14 v2\AIRESPACE-WIRELESS-MIB.cds, 190260 , 2018-05-10 v2\AIRESPACE-WIRELESS-MIB.cmi, 197047 , 2018-05-10 v2\AIRESPACE-WIRELESS-MIB.my, 623328 , 2010-04-06 v2\ALTIGA-ADDRESS-STATS-MIB.cds, 5772 , 2018-05-10 v2\ALTIGA-ADDRESS-STATS-MIB.cmi, 5948 , 2018-05-10 v2\ALTIGA-ADDRESS-STATS-MIB.my, 16780 , 2011-01-28 v2\ALTIGA-BMGT-STATS-MIB.cds, 2285 , 2018-05-10 v2\ALTIGA-BMGT-STATS-MIB.cmi, 2900 , 2018-05-10 v2\ALTIGA-BMGT-STATS-MIB.my, 6575 , 2011-01-28 v2\ALTIGA-CAP.cds, 1858 , 2018-05-10 v2\ALTIGA-CAP.cmi, 3518 , 2018-05-10 v2\ALTIGA-CAP.my, 7350 , 2011-01-28 v2\ALTIGA-CERT-STATS-MIB.cds, 3352 , 2018
©️2020 CSDN 皮肤主题: 书香水墨 设计师:CSDN官方博客 返回首页