JSONObject没有fromObject方法及其依赖引入

原因是导包导错了,需要的是下面这个包:

import net.sf.json.JSONObject;

 

而不是其他的包:

import com.alibaba.fastjson.JSONObject;

 

一、开发场景

Java开发当中经常需要Json格式的数据,这就用到JSONObject类,本文章只提供以下两种JSONObject对应架包的下载方式。
1、com.alibaba.fastjson.JSONObject(依赖1个架包fastjson-1.2.28.jar)
2、net.sf.json.JSONObject

(依赖6个架包commons-beanutils-1.9.3.jar、commons-collections-3.2.1.jar、commons-lang-2.6.jar、commons-logging-1.1.1.jar、ezmorph-1.0.6.jar、json-lib-2.4-jdk15.jar)
  文中Maven依赖下载需要不同版本的jar可以到maven仓库官网找到自己想要的版本的dependency依赖代码即可。maven仓库地址http://mvnrepository.com/


二、下载方法
1、方法一(直接下载)
下载地址(含1、2两种架包)http://download.csdn.net/download/justinqin/10158995
2、方法二(maven pom.xml依赖)

net.sf.json.JSONObject依赖

<!-- JSONObject对象依赖的jar包 -->  
        <dependency>  
            <groupId>commons-beanutils</groupId>  
            <artifactId>commons-beanutils</artifactId>  
            <version>1.9.3</version>  
        </dependency>  
        <dependency>  
            <groupId>commons-collections</groupId>  
            <artifactId>commons-collections</artifactId>  
            <version>3.2.1</version>  
        </dependency>  
        <dependency>  
            <groupId>commons-lang</groupId>  
            <artifactId>commons-lang</artifactId>  
            <version>2.6</version>  
        </dependency>  
        <dependency>  
            <groupId>commons-logging</groupId>  
            <artifactId>commons-logging</artifactId>  
            <version>1.1.1</version>  
        </dependency>  
        <dependency>  
            <groupId>net.sf.ezmorph</groupId>  
            <artifactId>ezmorph</artifactId>  
            <version>1.0.6</version>  
        </dependency>  
        <dependency>  
            <groupId>net.sf.json-lib</groupId>  
            <artifactId>json-lib</artifactId>  
            <version>2.2.3</version>  
            <classifier>jdk15</classifier><!-- 指定jdk版本 -->  
        </dependency>  
        <!-- Json依赖架包下载 -->  

 

如果需要fastjson的依赖:

com.alibaba.fastjson.JSONObject依赖

<dependency>  
    <groupId>com.alibaba</groupId>  
    <artifactId>fastjson</artifactId>  
    <version>1.2.28</version>  
</dependency>  

依赖部分内容来源于:https://blog.csdn.net/JustinQin/article/details/78799287

展开阅读全文

没有更多推荐了,返回首页