java.lang.ClassNotFoundException: org.apache.struts2.dispatcher.ng.filter.Struts问题解决

在eclipse中新建了ssh项目报错:1.java.lang.ClassNotFoundException:org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter,意思是找不到StrutsPrepareAndExecuteFilter这个类。我百度发现他在struts2-core的jar保中,而在webinf下的lib里边没有该jar包,将jar包放到webinf的lib下面,重新启动Tomcat,ok

2.java.lang.NoClassDefFoundError: com/opensymphony/xwork2/config/ContainerProvider

网上说是因为版本不对,xwork-core有两个不同的版本,一个是com.opensymphony,另一个是org.apache.struts.xwork的。

将xwork-core、struts2-core、struts-spring-plugin版本一致后,报下一个错。

3.java.lang.NoSuchMethodError: com.opensymphony.xwork2.config.ConfigurationManager.addContainerProvider

百度后重新检查jar包,应该是jar包冲突;再检查web.xml配置,原路是配置文件这错了

原来:

<filter>
        <filter-name>struts2</filter-name>
        <filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter</filter-class>
    </filter>
  

改后:<filter>
        <filter-name>struts2</filter-name>
        <filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareFilter</filter-class>
    </filter>

解决了这个

4接着报错line: 230 - com/opensymphony/xwork2/spring/SpringObjectFactory.java:230:-1

解决:不要引入包:struts2-spring-plugin的jar包

5.java.lang.NoSuchMethodError: ognl.SimpleNode.isEvalChain(Lognl/OgnlContext;)Z

ognl的jar包版本问题,换了一个高点的

  • 0
    点赞
  • 1
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:撸撸猫 设计师:马嘣嘣 返回首页
评论

打赏作者

Coding With you.....

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值