1040 Longest Symmetric String (25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

中心扩展法:让每个元素和每两个元素分别做为中心,向两边拓展,更新最大值,这里的测试用例数据量比较小,暴力求解也能过

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int func(string& s, int left, int right)
{
	while (left >= 0 && right < s.size() && s[left] == s[right])
	{
		left--;
		right++;
	}
	return right - left - 1;
}
int longestPalindrome(string s) {
	if (s == "")
		return 0;
	int Max = 0,start, end;
	for (int i = 0; i < s.size(); i++)
	{
		int len = max(func(s, i, i), func(s, i, i + 1));
		if (len > Max)
		{
			Max = len;
			start = i - (len - 1) / 2;
			end = i + len / 2;
		}
	}
	return end - start + 1;
}
int main()
{
	string str;
	getline(cin, str);
	cout << longestPalindrome(str);
	return 0;
}

暴力算法:

#include<iostream>
#include<string>
using namespace std;
bool func(string str)
{
	for (int i = 0; i <= str.size() / 2; i++)
		if (str[i] != str[str.size() - i-1])
			return false;
	return true;
}
int main()
{
	string str;
	getline(cin, str);
	for (int j = str.size(); j >= 1; j--)
		for (int i = 0; i + j <= str.size(); i++)
			if (func(str.substr(i, j)))
			{
				cout << j;
				return 0;
			}
	return 0;
}

速度对比:
中心拓展法:
在这里插入图片描述
暴力求解:
在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值