1102 Invert a Binary Tree (25 分)——PAT A

25 篇文章 0 订阅

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

【分析】二叉树的层序遍历&&中序遍历

总结:

层序用队列,中序用递归。

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;
const int maxn = 1e2;
int n;
bool isRoot[maxn];
int lchild[maxn], rchild[maxn];
struct tnode {
	int data;
	tnode *left, *right;
};
tnode* create_tree(int x) {
	tnode* root = new tnode;
	root->data = x;
	if (lchild[x] != -1) root->left = create_tree(lchild[x]);
	else root->left = NULL;
	if (rchild[x] != -1) root->right = create_tree(rchild[x]);
	else root->right = NULL;
	return root;
}
void level_traverse(tnode* root) {
	if (!root) return;
	queue<tnode*> q;
	q.push(root);
	while (!q.empty()) {
		tnode* p = q.front(); q.pop();
		if (p->left) q.push(p->left);
		if (p->right) q.push(p->right);
		printf("%d%s", p->data, q.empty() ? "" : " ");
	}
}
int in[maxn], id = 0;
void in_traverse(tnode* root) {
	if (!root) return;
	if (root->left) in_traverse(root->left);
	in[id++] = root->data;
	if (root->right) in_traverse(root->right); 
}
void solve() {
	int ans = 0;
	while (!isRoot[ans]) ans++;
	tnode *root = create_tree(ans);
	level_traverse(root);
	cout << endl;
	in_traverse(root);
	for (int i = 0; i < id; i++) {
		printf("%d%s", in[i], i != id - 1 ? " " : "");
	}
}
int main() {
	cin >> n;
	fill(isRoot, isRoot + n, true);
	fill(lchild, lchild + n, -1);
	fill(rchild, rchild + n, -1);
	for (int i = 0; i < n; i++) {
		char a[5];
		getchar();
		scanf("%[^\n]s", a);
		int left = a[2] - '0', right = a[0] - '0';
		if (left >= 0 && left <= 9) {
			lchild[i] = left;
			isRoot[left] = false;
		}
		if (right >= 0 && right <= 9) {
			rchild[i] = right;
			isRoot[right] = false;
		}
	}
	solve();
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值