关于Android 利用Android Device Monitor无法查看写入文件的内容

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/weixin_42894393/article/details/82415638

1、Android 7.0系统的模拟器无法正常查看File Explorer中的内容,新建一个Android 6.0系统的模拟器

2、方法二参考:https://blog.csdn.net/q394895302/article/details/52796883

3、真机测试出现上面问题可以看这个:http://www.mamicode.com/info-detail-1854799.html

展开阅读全文

android studio的android device monitor打不开

08-25

点击android studio的android device monitor提示如图对话框[img=https://img-bbs.csdn.net/upload/201608/25/1472129242_21709.png][/img]rn我按照提示查看了指定的log文本,可是看不懂,求大神指点,log文本内容如下:(文本不全,超出字符限制,感觉重复,删掉部分)rnrn!SESSION 2016-08-25 20:50:44.390 -----------------------------------------------rneclipse.buildId=unknownrnjava.version=1.8.0_91rnjava.vendor=Oracle CorporationrnBootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=zh_CNrnCommand-line arguments: -os win32 -ws win32 -arch x86_64 -data @noDefaultrnrn!ENTRY org.eclipse.osgi 2 0 2016-08-25 20:50:45.314rn!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:rn!SUBENTRY 1 org.eclipse.osgi 2 0 2016-08-25 20:50:45.314rn!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.ui_3.104.0.v20121024-145224.jar was not resolved.rn!SUBENTRY 2 org.eclipse.ui 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".rn!SUBENTRY 1 org.eclipse.osgi 2 0 2016-08-25 20:50:45.314rn!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.ui.workbench_3.104.0.v20130204-164612.jar was not resolved.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing imported package org.eclipse.e4.ui.services_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing imported package org.eclipse.e4.core.commands.internal_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench.addons.swt_0.10.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing imported package javax.annotation_1.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt.theme_0.9.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing required bundle org.eclipse.e4.ui.model.workbench_0.9.1.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.swt_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.314rn!MESSAGE Missing required bundle org.eclipse.e4.ui.bindings_0.9.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.e4.core.commands_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing required bundle org.eclipse.e4.core.di_1.1.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.modeling_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.emf.common.util_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.emf.ecore_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench3_0.12.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing required bundle org.eclipse.e4.core.contexts_1.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.w3c.dom.css_2.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package javax.inject_1.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing required bundle org.eclipse.e4.ui.di_0.9.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.e4.ui.workbench.renderers.swt_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.emf.ecore.util_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing required bundle org.eclipse.e4.core.services_1.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.e4.ui.workbench_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench.swt_0.9.1.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing imported package org.eclipse.e4.ui.internal.workbench.renderers.swt_0.0.0.rn!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-08-25 20:50:45.315rn!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt_0.9.1.rnrn!ENTRY org.eclipse.osgi 2 0 2016-08-25 20:50:45.326rn!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:rn!SUBENTRY 1 org.eclipse.osgi 2 0 2016-08-25 20:50:45.326rn!MESSAGE Bundle com.android.ide.eclipse.base_25.1.7.2879327 [1] was not resolved.rn!SUBENTRY 2 com.android.ide.eclipse.base 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.rn!SUBENTRY 1 org.eclipse.osgi 2 0 2016-08-25 20:50:45.326rn!MESSAGE Bundle com.android.ide.eclipse.ddms_25.1.7.2879327 [2] was not resolved.rn!SUBENTRY 2 com.android.ide.eclipse.ddms 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.ddms 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui.console_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.ddms 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.ddms 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle com.android.ide.eclipse.base_0.0.0.rn!SUBENTRY 1 org.eclipse.osgi 2 0 2016-08-25 20:50:45.326rn!MESSAGE Bundle com.android.ide.eclipse.gldebugger_25.1.7.2879327 [3] was not resolved.rn!SUBENTRY 2 com.android.ide.eclipse.gldebugger 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.gldebugger 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.gldebugger 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui.console_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.gldebugger 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle com.android.ide.eclipse.ddms_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.gldebugger 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle com.android.ide.eclipse.base_0.0.0.rn!SUBENTRY 1 org.eclipse.osgi 2 0 2016-08-25 20:50:45.326rn!MESSAGE Bundle com.android.ide.eclipse.hierarchyviewer_25.1.7.2879327 [4] was not resolved.rn!SUBENTRY 2 com.android.ide.eclipse.hierarchyviewer 2 0 2016-08-25 20:50:45.326rn!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.rn!SUBENTRY 2 com.android.ide.eclipse.hierarchyviewer 2 0 2016-08-25 20:50:45.326rnrnrnrn!ENTRY org.eclipse.osgi 4 0 2016-08-25 20:50:45.330rn!MESSAGE Application errorrn!STACK 1rnjava.lang.RuntimeException: Application "com.android.ide.eclipse.monitor.Application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error.rn at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)rn at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)rn at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)rn at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)rn at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)rn at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)rn at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)rn at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)rn at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)rn at java.lang.reflect.Method.invoke(Method.java:498)rn at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)rn at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)rn at org.eclipse.equinox.launcher.Main.run(Main.java:1438)rnrn 论坛

没有更多推荐了,返回首页